How to Get Archiving to work

I am a new user and i am a little nervous about removing the commercials and not keeping the original file for atleast some period of time. I believe i set it up correctly for what i want to do, but it isn’t archiving the files.

My setup has the files on the a external nas drive ( i have the username setup so it is able to read/write). Then i would like to archive to another external nas drive( there doesn’t seem to be a place for this username password), so i tried to archive to a local drive to see if that was the issue, but it still didn’t work. I have the log set to debug, but i don’t see anywhere that it mentions the archive directory. I am uploading the log from this attempt, but others with the local drive had the same results.

Under Monitor location, expert settings, i have archive original file checked and archive folder selected.

Bless This Mess S02E15 20200317 [20200318-0030].mpg-TVShows-2020-03-23T20-05-38.8995866-04-00.log (657.0 KB)

Archiving/deleting files after a conversion is completed is logged in the mcebuddy.log file, you can open that file and search for your filename to see what’s going on.

Archiving is configured for each Monitor task under expert settings. You can set the location to a NAS drive (starting with \\) and it will allow you to enter the username/password for that network location. Don’t use mapped drives.

I am uploading the logfile and it says the name of the archive directory, but i don’t see where it says it is doing anything about archiving (successful or failed).
This is a local drive and not a NAS drive for the test.

Also there isn’t a place for the username/password for the archive directory. There is one for the monitor directory and the destination directory.

mcebuddy.log (42.2 KB)

Your original file and converted file are the same (they have the exact same name so the converted file overwrites the original after conversion), so there’s nothing to archive. Archive only works when the original and converted files are distinct from each other.

INFORMATION> 2020-03-23T20:12:10 MCEBuddy.Engine.Core --> Job for \WDMYCLOUD2\HDHomeRun\Bless This Mess\Bless This Mess S02E15 20200317 [20200318-0030].mpg converted successfully to \WDMYCLOUD2\HDHomeRun\Bless This Mess\Bless This Mess S02E15 20200317 [20200318-0030].mpg using Conversion Task TVShows and Profile HDHomeRun Unprocessed

Yes, since all i am doing is removing commercials the file name will be the same. It seems like this could be done before it is replaced. Is there anyway around it?

I found this link: Archiving when destination filename is exactly the same as the source filename

and it works for my local drive. Guess i just need to figure out how to get the login info for the NAS drive to work.

I am not sure what else to try to get the copying to the NAS to work. I have created a new user with an account on the nas, set the service to use this user/password. I created the same user account on the starting NAS just to make sure all the accounts were the same. Mapped the drive on the user’s account and running the mcebuddy app from this account. The error seems like the user doesn’t have access, but i know that is incorrect. I tried with the UISession true and false.

Hopefully someone can assist. I am sure i am close.

Drunk History 20190114 [20190114-0940].mpg-TVShows-2020-03-25T18-59-13.8236869-04-00.log (599.2 KB) Drunk History 20190617 [20190617-0825].mpg-TVShows-2020-03-25T19-05-14.2410114-04-00.log (608.2 KB)

Not sure how i missed the line when you said to not use the mapped drive. That must have been the issue.

One question i do have is why does the user for the service need to be an admin user? When i had the mcebuddy user as just a regular user, the service wouldn’t start correctly. I have another program that uses nas drives and it worked with a regular user.

No there’s no corelation between the user and mcebuddy running. MCEbuddy runs as a system service by default (unless someone manually changes it).
As a system service it doesn’t have access to user mapped drives as explained on this page, second post: MCEBuddy - Solution to Common Issues and Errors

You can however run mcebuddy as a command line engine from the user login from the start menu which gives mcebuddy access to mapped drives, but then it no longer runs in the background and only runs as long as the user is logged in.

Maybe it is different than BlueIris is, but i had to run the service as a local user instead of the system user to get the NAS to work. That is what they stated in their help files. So i tried the same with mcebuddy and the user not being an admin user gave me errors in the event logs when it tried to start up and the program said the service wasn’t running. When i made the user an admin user it started fine. Not sure if i want to go back at this point, i spent most of the afternoon getting it to work.

Right now it is working with the service running using the user i created. Switching from the mapped drive is probably what fixed the problem.

You can check out today’s build. Now you can specify a custom username/password for each network path. So temp folders, failed folders, archive folders, monitor paths, destination folders etc each have their own network credential option.

Cool, thanks! I will try it.