Using mapped drives to NAS server on Windows 10

So i have read everything I can find on your discussion site and tried them all with no success. I have a NAS with Plex and Live TV DVR setup so it captures from my HomerunConnect via Plex to a NAS share. Iwould like MCEBuddy to monitor that share and convert the files to smaller format and remove commercials and drop it in a different folder on that same NAS share drive. I have tried going into the GENERAL SETTINGS and adding the network authentication using my map drrive creds to my NAS and then updating the profiles with just my local workstation user creds. I have tried leaving them all as guest. I have tried using the map drive share creds in the profiles. I have tried all of this using the standard and command line version. I even went and got SystemInternalsSuite and created a map drive under my local SYSTEM account so it would be mapped to the system. Nothing works. Out of ideas and very frustrated

mcebuddy.log (811.0 KB)

This is likely your problem. You are using a mapped drive name. Mapped drives don’t exist in system context, only in user login context and MCEBuddy runs as a system service in system context.

Search Path -> P:\DVR

Change your path to a network path like \\network\share and it should work fine with the credentials. Same for your destination folder.

See the Common issues page for details on this topic.

Also ensure that your NAS date time is matching the comouter date time. One user had noted that the date times didn’t match the authentication fails.

Tried it that way as well before and I get the same result. Is there a Linux version of this?


September 2
This is likely your problem. You are using a mapped drive name. Mapped drives don’t exist in system context, only in user login context and MCEBuddy runs as a system service in system context.

> Search Path -> P:\DVR

Believe i fixed it. I built all new monitor and destination and put creds in since my drive is mapped already and presto it worked this time

1 Like

I’ve been having trouble with this like crazy too, I had to drag and drop files in all last season, so I figured I’d try to nail it down this season. I have a Kodi box with a mounted USB drive that is shared \kodiname\My Passport\Recordings
I get this error which I think has to do with the share name, most likely the space in My Passport not being supported?
ERROR : The given path’s format is not supported.

If the space is the problem, I’m not sure how to rename a shared mounted USB drive in Kodi, but at least that’d be a start.

I’ve tried mapping the drive first, then pointing the monitor to R:, but I get
ERROR : Could not find a part of the path ‘R:\’.

I know it has to be one little mistake somewhere, but I’ve been racking my brain for months.


Did you see this post:

Mapped drives don’t exist in system space and MCEBuddy runs in System space. You have use Network URL’s like \\server\sharename AND you have to enter the login credentials for the remote share along with it (look for the key icon next to it).

Try ending your path’s with and without a \

It will help if you attach your log file or the complete error and exact path you’ve used in your settings.

Hi RBoy,
Yeah, I did see that post. I don’t use mapped drives, but was trying it because I read Jeffrey’s last post as he got it working, he just had to add a second location. I usually use the IP address or share name, but I’m not sure if those both work the same

Here’s the log file trying both ways. I’m sure I have a login messing things up somewhere, it gets confusing having them in different spots, one under System, one for monitoring, etc. I do get a different error when using the IP address vs. server name.

mcebuddy.log (57.1 KB)


Lets keep this a little simpler since I had other errors at the beginning of that log, I’m trying too many different combinations. This setup looks correct, just getting the “given path’s format is not supported” error. The shared location is on an Odroid C2 using LibreElec mounted with a USB external drive, in case the “given path format” is referencing an issue with the source directory’s structure.

mcebuddy.log (20.6 KB)

Hmm I’m wondering if the IP address is causing the issue. Try using a machine name instead and I’ll also try to check

Yeah, I was trying the machine name first, that’s where I noticed the “path’s format is not supported” error. I’ve read some posts mentioning Unicode issues, not sure what the format is being referred to in this case. I’ll try finding out how to rename the share to a simpler format on the kodi machine, something without the space in “My Passport”.

Here’s the log with the machine name being used.
mcebuddy.log (22.6 KB)

Okay, that worked and was easier than I thought. Plugged it into the desktop, disk management->properties and changed the name to “Passport”. Plugged it back into the kodi machine, it mounted with the new name, then changed the monitor location in MCEBuddy to the new name and it grabbed all the recordings right away. I thought I was going to have to SSH or build some custom boot config file. That’ll save me some hassle once all the new shows air and record. I think I found the Unicode tip on some C# programming threads, I don’t remember seeing anything about acceptable naming formats in any of the MCEBuddy troubleshooting sections. Might be a useful tip if that is the case.


1 Like

So you were using a Unicode name for the machine or mount ?

For the mount, the external drive from Western Digital had the name “My Passport” preset for the drive. I renamed the external drive to “Passport”.

So my share path name was:
\lkodi\My Passport\Recordings

I updated it to:

1 Like

I have been trying to get to work for many hours now. Have a new raspberrypi server running Plex server in OMV. I am trying to replace my Windows Plex server, where I have MCEBuddy2x converting on the fly, and doing a great job. I never would have expected that the MCEBuddy2x would occupy most of my configuration efforts.
With my monitors setup to use \server\share, I am getting steams of errors like this one…
ERROR> 2018-05-20T21:36:45 MCEBuddy.Engine.QueueManager --> Unable to search for files in location \raspberrypi\Media\Movies for monitor task Movies
ERROR : The network name cannot be found.
I wonder if it is related to my Windows Explorer Network discovery not showing the OMV server in the workgroup. I had been trying this with a mapped drive, which I now know doesn’t work.

Yes, windows can’t resolve the computer name/path

You’re right mapped drives don’t exist in System/Kernel space where MCEBuddy runs, so you can’t use mapped drives unless you run the MCEBuddy engine from your user account and not as a service. See this FAQ:

On My machine

Tried for ages to get UNC / Mapped dirve working

Solution: Enter the drive path in MCEBuddy, then click the key icon to the right of where this is entered and type Guest in the Username if you have no login information. (or fill in any login details there)

Nothing to do with windows or system space, just missing the word “Guest”

1 Like

That’s correct and the best option, quoting from the FAQ on how to use network mapped drives: