Videos convert much quicker with GPU physically removed from computer

Relevant specs:
Donator versions of both MCE buddy and Comskip
Video Card: Radeon r7 240 it has Open CL
Mobo: Asus B85M-E/CSM

I determined that when I physically disconnect the video card, MCEBuddy converts much quicker. A 2 hour MPEG2-TS video takes over 2 hours with the video card connected, but only takes under 1 hour with it disconnected.
I currently have the latest stable Intel Graphics driver installed as suggested by MCE Buddy. I’ve tried the other stable driver versions listed with no luck either.

Have tried adding -P to the profile but processing seems to slow down even more from that.

In the BIOS, I was only able to find 2 options; one called “iGPU Multi-Monitor” which I enabled, and “Primary Display” which I set to PCIe card.

I’ve attached two log files, one from a file with the GPU connected (GPU…txt) and another from the same file with the GPU disconnected (NO_GPU…txt). I ran MCE Buddy on the file with the GPU connected and waited until it completed. Then, I turned off my computer, removed my GPU, and ran MCE buddy again without changing any settings (except for one to allow MCE Buddy to pickup the previously converted file).

EDIT: I have also tried installing Intel Media SDK 2016 (did some digging and found a forum on Google with someone claiming this worked) but that did not help.

Any help is much appreciated and if there is any additional information I can provide please let me know!

GPU_Dragons’ Den (2006) - S12E01 - Episode 1.ts-Convert to MP4-2017-10-01T08-54-26.5514755-04-00.log (9.2 MB)

NO_GPU_Dragons’ Den (2006) - S12E01 - Episode 1.ts-Convert to MP4-2017-10-01T11-27-25.2532110-04-00.log (3.2 MB)

If you look at your logs you’ll noticed that in your GPU enabled conversion, the GPU conversion is failing and then falling back to software encoding.

2017-10-01T09:16:50 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 0.71 % (33.70 fps, avg 28.06 fps, ETA 03h39m13s)[mp4 @ 0000000006297ea0] pts < dts in stream 0
2017-10-01T09:16:50 MCEBuddy.AppWrapper.Handbrake --> ERROR: avformatMux: track 0, av_interleaved_write_frame failed with error ‘Error number -22 occurred’

This could be for a couple of reason as I know:

  1. Handbrake is buggy
  2. Your drive is buggy

First try using the 2.4.8 BETA version of MCEBuddy, it has updated version of Handbrake or you can download the latest version from Handrake from their website and replace it in the MCEBuddy installation folder.

For the second use the recommended driver version, your current version is:

driver version:

Thanks for the reply Goose!

Sorry, I mistakenly followed your advice in the opposite order.

I ended up using a different file but I don’t suspect this would be an issue since it’s the exact same input format. The 2nd file is much smaller, so I was able to get to the conversion progress bar quicker to see the estimated time. I could tell by the estimation that there was no improvement in speed so I only have partial logs, but I believe there’s enough info to debug.

I had to install driver version as it’s the only one that works with Windows 10 (and I had missed it was labeled as such. must follow directions below exactly in order to get it to install properly). After that install, the first log file was generated, GPU_PROPER_DRIVER…txt. Conversion speed was no slower or faster than with GPU…txt log.
GPU_PROPER_DRIVER_The Big Bang Theory (2007) - S11E02 - The Retraction Reaction.ts-Convert to MP4-2017-10-02T20-57-45.4762586-04-00.log (3.1 MB)

Then I updated to MCE Buddy Beta 2.4.8 to generate GPU_PROPER_DRIVER_MCE248…txt. With this update, conversion appears to take twice as long; from 30 minutes to 1 hour.

GPU_PROPER_DRIVER_MCE248_The Big Bang Theory (2007) - S11E02 - The Retraction Reaction.ts-Convert to MP4-2017-10-02T22-32-40.0981448-04-00.log (685.2 KB)

I actually recall that with a previous file of the same size as this one, and NO GPU, estimated time was 15 mins. Which aligns with the 1 hour processing time of the first file with NO GPU(video duration / 2).So, with these updates, I have seen no improvements in speed.

Your logs are showing that you system isn’t using hardware encoding but instead falling back to software encoding.

2017-10-02T22:38:52 MCEBuddy.AppWrapper.Handbrake --> [22:38:52] qsv_enc_init: using ‘software’ implementation, API: 1.23
2017-10-02T22:38:56 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 0.13 %
2017-10-02T22:38:58 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 0.17 %
2017-10-02T22:39:00 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 0.20 % (7.26 fps, avg 13.90 fps, ETA 00h44m30s)

This would indicate an issue with your graphics drivers or hardware. Try using a different driver, maybe the latest Microsoft WHQL driver or the the latest one from Intel’s website. You’ll have to try different versions until you find out that works.
Maybe also try this version of Handbrake and see if makes a difference.

Your other logs shows that the encoder is failing due to a corrupted video:

2017-10-02T21:06:59 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 2.57 % (8.27 fps, avg 8.83 fps, ETA 01h08m25s)[mp4 @ 0000000006af0f00] pts < dts in stream 0
2017-10-02T21:06:59 MCEBuddy.AppWrapper.Handbrake --> ERROR: avformatMux: track 0, av_interleaved_write_frame failed with error ‘Error number -22 occurred’

Are you facing this problem just a single video or all video files?

My next thought was going to be try using the latest Intel driver. It didn’t make sense that the old but recommended Intel driver without the BETA MCE Buddy was quicker than the same with the BETA version.

The speed is an issue with all videos. But I’ve never had a file fail to convert, I always end up with a working MPEG-4.

Updated my intel driver to the latest version and it’s still just as slow, estimating about 1 hour for conversion. Here’s a partial log:

GPU_LATEST_DRIVER_The Big Bang Theory (2007) - S11E02 - The Retraction Reaction.ts-Convert to MP4-2017-10-03T19-57-20.7022053-04-00.log (683.7 KB)

Can you upload one of the original videos to the MCEBuddy server, let me take a look at it and see what’s going on. I wonder if the hardware decoding which could be creating an issue for you. Let me play with it.

You can find the instruction on uploading file in the Read Me before posting post:

My thought is to set the intel gpu as primary that way mcebuddy will use it for hardware transcoding. As far as I know mcebuddy only supports hardware transcoding on intel and nvidia.

How would I do this?

Does this mean I could still have my dedicated gpu attached and available to use for gaming, but have MCE Buddy just use the onboard gpu?

And if that’s the case, you’d think the software would switch to the onboard gpu and I wouldn’t have any issues.

Thanks for the help!

you mentioned earlier in the thread that you had the option in the bios for “Primary Display” try changing that but be ready to connect your monitor to your intel gpu just incase. As far as gaming goes, I am not a gamer so I would not know. Also, the Radeon r7 240 is quite old I would recommend returning that and getting a quadro P400. They are in the same price range and it should be good for gaming. It is also single slot and bus powered. Did I mention that mcebuddy runs great on it.