Intermittent hardware encoding failure

I have noticed that my hardware encoding times have tripled for some of the OTA shows I DVR. Can someone look at these logs and tell me what is happening so that I can try to fix it please.

The Good Doctor from 2017-11-15 converting time was 8mins 51sec, total time was 22-04
The Good Doctor (2017) - S01E07 - 22 Steps.ts-Convert to MP4-2017-11-15T05-37-34.3684415-06-00.log (932.4 KB)

The Good Doctor from 2017-11-21 converting time was 7mins 50sec, total time was 19:51
The Good Doctor (2017) - S01E08 - Apple.ts-Convert to MP4-2017-11-21T03-51-44.2098123-06-00.log (806.3 KB)

The Good Doctor from 2017-11-28 converting time was 59mins 51sec, total time was 1:13:39
The Good Doctor (2017) - S01E09 - Intangibles.ts-Convert to MP4-2017-11-28T02-10-03.0498242-06-00.log (1.3 MB)

Not sure what changed, I might have messed something up not sure just want the very fast times back again please. Om November 21, some file got corrupted so had to use a backup to MCEBuddy working again (thanks Goose) but my times have been horrible since not sure what I need to do to get them back. Here is a link to that post: MCEBuddy Service is unavailable error on pc startup .

Here is my config file (I remember it was needed last time):
mcebuddy.conf (3.5 KB)

Was trying to do my own research so was comparing the 2 logs side by side and found this (not sure why the encoder is different but it is and I know that (intel media sdk is my qsv, however I have hardware encoding checked) (2017-11-15 is when i was trying to figure out close captioning for roku):

OK I swear all I think i did was change the audio language from default to eng and how it seems to working like it before (but who knows maybe i messed something else up to fix it lol).
mcebuddy.conf (3.5 KB)

And a screenshot showing the processing of the exact same source file The Good Doctor (2017) - S01E09 - Intangibles

Would still like to know if just changing the audio is all it took just in case this happens again, or in case I have run across a bug or something.

UPDATE - I changed the audio back to default and it still processed at fast speed - no clue why for a week it wouldn’t. Also it is usually to have my cpu run at 100% while using QSV, saw that today and was wondering if that was audio or something or if something more is wrong.

Your graphics driver is culprit, it’s unstable, maybe some program running in the background causing it to hang or take up lots of resources or the computer just needed a reboot:

Error code -17, hb_qsv_wait_on_sync 602

ERROR> 2017-11-28T02:29:17 MCEBuddy.AppWrapper.Handbrake --> Hardware encoding appears to have hung, no progress in the last 300 seconds.

When in doubt look for the ERROR> lines in the log to tell you what’s the likely issue.

1 Like

Same thing happend again - I rebooted last time and it fixed it this time it didn’t.

Is this an issue with Handbrake of Mcebuddy or what and how can i fix it?

Recent log
Blindspot (2015) - S03E09 - Hot Burning Flames.ts-Convert to MP4-2018-01-12T23-32-47.7302035-06-00.log (1.1 MB)

Neither, it’s your graphics driver that causing the hang. Handbrake hands off the encoding to the graphics driver and intel is notorious for unstable drivers.

Try a different version of the driver or one of the recommended versions of the intel graphics driver.

1 Like

updated to the driver listed in that thread and still not working. Any troublshoting ideas?

How can I check the actual driver installed to be able to include a screenshot of it for verification here? Should I uninstall handbrake? its a i5-3570k if that helps. Was working good for a month on all files now it fails back on every single file.

I did update to the newest beta mcebuddy to see if that might help, this file was done after the update and still gets hungup.

So I think i managed to check the driver version but if i did it right then something went wrong:
Your FAQ says it should be driver 10.18.10.3958 (build 15.33.30.3958) however doesnt look like that is the one installed even though I went through the install correctly and rebooted

I remember reading something about the updated windows witll default to update drivers and that it needs to be turned off, might this be a problem?

The Big Bang Theory (2007) - S11E13 - The Solo Oscillation.ts-Convert to MP4-2018-01-15T16-42-12.3996567-06-00.log (994.3 KB)

I appreciate the help very much.

Going to try uninstall existing before installing new since I have tried twice to install over the existing.

UPDATE: Unless the driver in FAQ is actually 10.18.10.4358 (or shows that once installed) for the life of me I am unable to install 64bit - Dropbox - Intel_ 10.18.10.3958 x64_15.33.30.3958.exe from the FAQ page.

I did a complete uninstall device, reboot, install the .exe file, reboot, and it still shows 10.18.10.4358 as the installed driver. Not sure what I can do differently.

Any help appreciated

Before uninstall:

After uninstall and reboot:

installing driver from faq page (no clue how it shows 10.18.10.4358 a this moment):
1_16_2018 , 1_30_10 PM_ver001

After reboot:

What are the bandbrake settings that correspond to MP4 Normal in mcrebuddy? I wan to try running the file solely through handbrake to see if the issue is there.

Have been trying all means of driver install, I could really use some help now. Not sure why all of the sudden this is back again and not sure why I can not install an older driver. I am probably missing something since I am spending upwards of 6 hours a day trying to get this working - I have to have for my cordcutting OTA system to work so wife is breathing down my neck and unable to watch any TV right now leading to much anger.

If it takes offering payment I would be willing to do that to get this working - just let me know. I have teamviewer installed for assistance already.

I am prepared to clean wipe the pc and reinstall everything, ready to try anything, just need help.

You can turn off hardware encoding in the Conversion Task -> Expert Settings page.

Windows automatically updates the drivers for you if you have Windows update enabled.

If you want your driver to be forced to a specific version, in the device manager for your graphics card click on Update driver, select “Manually” and then select the driver version you want (if it’s installed) or point it to the place where you’ve extracted your graphics driver files. Once done you should see the correct version in the Driver Details tab.

Were you able to resolve this, as I have the same issue. I tried installing the driver listed on the page and it complained that my i3-7100u doesn’t meet the minimum standards. I am running windows 10 but the driver listed is for windows 7 and 8.

Thanks!
News 4 San Antonio at 10p_20180213_22302305.ts-Remove Commercials and Compress-2018-02-14T05-31-00.4819622-06-00.log (1.5 MB)

To be honest I didnt. I had reinstalled all drivers available (i mean at least 6 different drivers) and nothing worked. Usually the help here is great and work with you until you get it working but took awhile to get the last response and it was about how to turn off HW encoding which is not what I was wanting at all so I gave up completely and spent the money to replace the Rokus with FireTV 4k that plays the OTA files format of mpeg2 interlaced without the need of transcoding.

I want to work on this again but after spending over 20 hours on it and help not being there even though I offered money not sure when I will try again.

Looks like it starts out with your hardware encoder but then your graphics driver has trouble encoding the video:

2018-02-14T05:56:03 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 63.84 % (63.48 fps, avg 61.60 fps, ETA 00h06m25s)Error code -21, hb_qsv_wait_on_sync 602
2018-02-14T05:56:03 MCEBuddy.AppWrapper.Handbrake --> ERROR: encqsv: MFXVideoENCODE_EncodeFrameAsync failed (-21)

I know Intel graphics drivers are very quirky and unstable so it can be difficult to find the right now. We have (I think) 3 drivers listed on our recommendation page. Did you try all 3? These are recommended on community feedback and general testing and are relatively stable for hardware encoding purposes.

If none of those three work try to use one of these drivers:

  1. The latest intel driver from Windows Update (uninstall all your old drivers and then have windows update install the latest one)
  2. Install the latest WHQL certified driver from the Intel website
  3. Install the latest driver available on the Intel website

Keep us posted on how it goes

Goose,
I am running Windows 10 on a Kaby Lake i3 NUC and whenever I attempt to install the drivers from dropbox it complains that my system doesn’t meet the requirements. I suspect that is because the drivers are for Windows 7/8. I used “Update Driver” and it did detect that my 10/2017 driver was out of date and updated to a 12/2017 driver so I am trying that. I’ll let you know the results.

Ok, updating to the December drivers fixed the issue.

Before:
The.Amazing.Race.S30E09.ts-Remove Commercials and Compress-2018-02-14T22-06-22.9652999-06-00.log (2.7 MB)

After: The.Amazing.Race.S30E09.ts-Remove Commercials and Compress-2018-02-15T10-35-28.8185142-06-00.log (1.3 MB)

Thanks!

1 Like

Can you share the drivers version numbers and if possible the links to the driver files so we can save them for future reference.