Hardware encoding worked in 2.4.7 but stopped in 2.4.8 and 2.4.9 beta


#1

I uploaded my log and video files for the issue. What I see is FFMPEG gets set to the primary conversion method, and then is replaced with MENCODER which attempts to verify QuickSync and fails after multiple attempts and finally uses setting for software conversion.

I see lines where the GT730 NVIDIA card is recognized and the Intel 630 as well, but hardware encoding never seems to kick in. Any suggestions?


(RBoy) #2

Can you attach your conversion log


#3

Sorry, followed the instructions of the FTP site and didn’t add a link:
ftp://upload.mcebuddy2x.com/jpyatt/TheGoodDoctor.log


(RBoy) #4

So a couple of things you need to be aware of:

  1. The order of your encoders:

order=handbrake,ffmpeg,mencoder

This means it’ll use handbrake first (QuickSync) and then ffmpeg
(NvEnc/CUDA) for hardware encoding.

You have BOTH, QuickSync and CUDA available. In the earlier version due to
a bug in MCEBuddy if both were found it would use ffmpeg first (cuda) and
then handbrake (quicksync).
With 2.4.9 of both hardware encoders are found it’ll use the user specified
encoder first (in your case handbrake, ie. quicksync).

So when it starts QuickSync encoding, the Intel graphics driver fails.

2018-03-15T13:28:46 MCEBuddy.AppWrapper.Handbrake --> Handbrake
failed, non 0 return code

This is likely due to a bad graphics driver, try installing one of the
recommended drivers version to get your QuickSync encoder working.

Because the hardware encoder fails, MCEBuddy tries to use the software
version of the same encoder (i.e. handbrake) and this works and this is
what you’re seeing.

MCEBuddy does not try the second available hardware encoder before falling
back to software encoder, this is a known issue and it’s slated to be fixed
in the next version.

Basically you’re facing this issue because your system supports BOTH Cuda
and QuickSync.

The simplest solution is to:

  1. Fix your Intel graphics driver to that QuickSync works
  2. Change the order in your profile to

order=ffmpeg,handbrake,mencoder

This make MCEBuddy use CUDA/NvEnc first and hopefully that driver is more
stable then you Intel driver and hardware encoding will be successful.

The dual hardware encoder issue will be addressed in the next release


#5

Thanks for the help. I updated the Intel driver from the Hardware encoding FAQ and eventually everything worked. A one hour show from Windows Media Center converts with commercials removed in 14 minutes. Awesome.


(Bob) #6

I’ve got a Sandy Bridge i7 2600 cpu and now a nvidia quandro p2000 and I want to get hardware encoding working, but I tried to install the recommended driver: Intel 2010.18.10.3958 x64_15.33.30.3958 as recommended above but it says my hardware doesn’t meet the minimum requirements and wouldn’t install.

Is there some other recommended driver? Or should I just skip the quicksync support and use just change the order of encoders as you suggested above?

Thanks.


(Goose) #7

Depends on what you want to use, if nvidia hardware encoding then you don’t need the intel drivers just use the encoder reordering or if you’re on the latest 2.4.9 version it’ll pick the ffmpeg profile automatically since that’s the only available hardware encoder.

PS - there are multiple recommended driver options you can try including some newer ones for win 10


(Bob) #8

I think I must be missing something, because I installed 2.4.9 and it works fine for software encoding. But I can’t find any

  nvenc, anywhere in either the mcebuddy.log or in the individual video file logs. I made sure to install the cuda developers kit

  and checked the 'hardware acceleration' box in mcebuddy. I also changed the order of the encoders so ffmpeg is first, still

  no joy.

  What could I be missing? Is there something else that is required to get it to use my hardware?

Thanks.


(Goose) #9

Attach your conversion log.