The mcebuddy service is unavailable

this began a few days ago while on version 2.5, did a clean install to version 2.6 and still having same issue. The service is running, tried service restarts, reboots and still states the service is unavailable.

can you attach your mcebuddy.log?

I am unable to locate mcebuddy logs. when I click on “logs” nothing appears, when I click on “events” I get a window with:
error retrieving event logs, unable to get event log entries from the mcebuddy engine, retrieving event logs from local machine. This displays much info but I don’t know where the file is that contains this info. I did a C drive search for mce.log with no results.
My environment is Win 10 using NextPVR with HomeRun OTA tuner boxes to record shows as TS files, which MCEBuddy then converts to Mpeg during inactive recording hours. I have been using this for many years without issues. When MCEBuddy stopped connecting to the service I did an upgrade to 2.6.x from 2.5.x, however I failed to do a an uninstall, so I followed guide to remove all file before doing a clean install.

Very strange. Can you open up a PowerShell as Administrator and enter the following:

Get-Service -Name MCEBuddy2x | Format-List -Property *

Paste the results in a response.

Can you also paste a screenshot of the main GUI window? Like this.

So strange. It should be able to connect/see the service is running. Are there any files in the Logs directory? Try this powershell command and paste output in reply.

Test-NetConnection -ComputerName localhost -Port 23332

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.
Try the new cross-platform PowerShell Install PowerShell on Windows, Linux, and macOS - PowerShell | Microsoft Learn PS C:\Windows\system32> Test-NetConnection -ComputerName localhost -Port 23332 WARNING: TCP connect to (::1 : 23332) failed WARNING: TCP connect to ( : 23332) failed

ComputerName : localhost
RemoteAddress : ::1
RemotePort : 23332
InterfaceAlias : Loopback Pseudo-Interface 1
SourceAddress : ::1
PingSucceeded : True
PingReplyDetails (RTT) : 0 ms
TcpTestSucceeded : False

PS C:\Windows\system32>
not sure where the logs directory is located, there’s not one in the MCEBuddy2x folder

Yes, the logs should be on the root of the MCEBuddy2x folder.
It looks like something might be blocking the communication to the service on port 23332. Or it could be that the service even though it shows are running, it might be in state of non-responding.
Open up the services and open the propeties of the MCEBuddy2x service. Attach a screenshot of this.


a few days ago i tried changing the port to 2121 in the conf file but it never showed the change so I changed it back, just fyi

I’m at a loss on why it’s not working. My only suggestion would be to retry the clean install method.

I will, I’ll post after, thanks for your help

No problem, sorry I didn’t have a better solution.

interestingly the MCEBuddy uninstall program indicated it could not proceed as the program was not installed. I did a an application remove from windows plus manual delete of all MCEBuddy referenced folders and files. After a Windows restart the MCEBuddy install went without issue and now it finds the service and works correctly. Still a bit odd why it originally failed under 2.5.x and 2.6.x install had same issue, but before this last install I was more diligent with cleaning out old MCEBuddy files.

Wow, no clue how it got some messed up, but glad it’s working now for you.