The MCE Buddy Service is Unavailable (latest Windows 11 build)

I have been using MCEBuddy 2.5.6 (64bit) without issue (mostly without issues) for many years now.
Windows shows that the MCEBuddy service is running, but the GUI is not recognizing the service.

“The MCEBUDDY service is unavailable. Please start from Windows control panel or check engine connections.” – is displayed on the GUI.

Ryzen 7 5700G
Asus B550 MB

Windows 11 x64 (22000.132)
MCEBuddy 2.5.6 and 2.5.7 (64-bit)
I am not running any third-party antivirus, firewall,
mcebuddy.log (583.1 KB)

From Computer Management, it appears that the MCEBuddy Service is running and appears as “running” in Task Manager’s Details view - however, MCEBuddy GUI is not seeing the service.

I have tried the following to try and remedy the problem:

    • turned Windows Firewall off
    • Turned Windows Ant-virus off
    • re-installed MCEBuddy with the latest from the web, 2.5.7
    • replaced both the .config files with the backed up, known working versions
    • manually added MCEBuddy.GUI to Windows Firewall
    • Verified that port 23332 was not used by another program
    • Reset Windows “Network” settings
    • replaced both the .config files with clean versions I had saved from a clean install
    • full uninstall and reinstall of MCEBuddy (deleted the saved .config files from the user/home folder)
    • MCEBuddy.conf - (shut it down) and as a “hail mary” I changed the upnpenable=trye, firewallexeptionenable=true – and stared the service back up again - no change.

What am I missing? Any suggestions?

Thank you in advance, John
(attached is my log file)

No idea if this will work but I’m running 11 and don’t have any issues. Go into System Settings and turn off Enable UPnP. That’s my best bet on what’s causing your issue. I don’t have it enabled.

Likely Microsoft changed the method that applications are allowed to make UPnP requests for increased security.

My previous Windows 11 dev build was working properly, but after last weeks update it isn’t any longer - or who knows?!
I obviously can not make the change to UPnP the way you are suggesting because the GUI isn’t finding the MCEBuddy Service.
I just shut down the Service and changed the mcebuddy.conf back from True to False [UPnPEnable=False]
Started the Service again and I have to same issue - service unavailable.
Other than looking in Task Manager, is there any other way to see if the MCEBuddy Service is actually running?

I just had Windows do a clean install and all is good in the world again!
I don’t know what setting messed up MCEBuddy, but after a clean install everything is working perfectly.
Thank you.

Glad you got it working. It didn’t even trigger in my mind that the service has to be running in order to modify the settings for some reason. For future reference for anyone else in the mcebuddy.conf here are the entries that @John_Freiman referenced

1 Like