MceBuddy 2.3.13 vs 2.5.4 - PlayOn AdSkip vs Comskip

Deletes Commercials on the old 2.3 and not on the new one. Tried MP4 unprocessed and MP4 high quality from Playon Video (Snowpiercer). Works on MPG/TS videos from HD HomeRun using TS unprocessed on both. Using Donator version of ComSkip.

Will need your conversion logs to see what’s going on. Are you using a custom comskip ini? If so check that it’s configured properly, you can set the ini file for each conversion task in the Conversion Task -> Expert settings page

so far there is no problem with mpg from HD HomeRun or with MP4 with Paramount’s “Yellowstone” or with AMC’s “Walking Dead” so for right now it is just TNT’s “Snowpiercer” and all of them work with ver 2.3 successfully deleting commercials. So there is that.

Do you work for them or are you just a helpful user?

If commercials aren’t being detected then it’s related to Comskip INI configuration (which defines the rules for detecting commercials). I’m assuming there no failure is conversion and just a detection issue here.

Will need a conversion log file from the the working and non working setups to compare and see what’s going on with your setup. You can find more details about tuning Comskip commercials here: Tuning Comskip and Custom Comskip INI's (Country / Channel specific)

That’s right, as I mentioned in my follow-up emails that using the same Comskip config I found, since I first encountered it, that it is only certain mp4 videos. I also found that it also applies to certain HD Home Run files that are mpg.

I wanted to take advantage of the additional features of the new version like the MP4 Unprocessed and possibly faster speed but found that the speed was faster, but not that much and as it turns out the old one is deleting commercials in a more reliable way.

I think I will just be staying with the old version for now. I use Playon with AdSkip unless I have to download from Spectrum directly rather than the underlying channels or through Hulu basic, so my needs as not a great as they used to be. It is just a sometime need and broadcast news shows that need to be de-cluttered.

But thanks for your help and insight.

That may explain the difference, the older 2.3.13 doesn’t support PlayOn with AdSkip and always runs comskip. The newer version supports PlayOn, so it find the ad markers in the MP4 file, it’ll use them instead of running Comskip. If it doesn’t find the ad markers from AdSkip then it’ll run Comskip.
If you can attach the conversion logs from both the MCEBuddy versions for the same file, I’ll be happy to look into them and see what exactly is going on.

I have logs from Snowpiercer MP4 from the 2.5 MP4 Unprocessed but I ran it TS Unprocessed on 2.3 where it worked. Will that be ok, or I can run it TS unprocessed on 2.5 if you want.

Let’s start with what you have and take it from there.

This is the one that worked on two episodes TS Unprocessed on 2.3. I have to get the one that didn’t from another computer where I am running 2.5

Snowpiercer - s01e07 - The Universe Is Indifferent.mp4-Convert to MP4-2020-07-06T14-32-41.5187553-04-00.log (955 KB)

Attached is the TS Unprocessed from 2.5 that did not work. Just a note - this one worked with The Movies and TV player and VLC on Windows 10. The one that worked on 2.3 was glitchy and unwatchable on Movies and TV and perfect on VLC.

Snowpiercer - s01e07 - The Universe Is Indifferent -.mp4-Mpg to TS unprocessed-2020-07-06T19-44-56.log (742 KB)

Exactly as I had suspected, 2.3.13 doesn’t support PlayOn so it runs Comskip always. 2.5.4 does support PlayOn AdSkip so it uses the embedded ad markers and skips running Comskip.
If you prefer to have 2.5.4 not use the embedded ad markers from PlayOn then you can disable that option in Conversion Task -> Expert Settings -> Check chapters for Ad markers and it’ll run Comskip instead.

I looked at a lot of logs and got familiar. The one at 9:56 is for a file that was recorded at 9:04 and I compared the start of each commercial break (not each commercial because I am not a masochist). The log seems to indicate that it identified and cut 3 commercial breaks, but each start of each of the 5 commercial breaks is identical in the original and in the converted and as I skipped forward there were several commercials in each break. So if it did do 3, it only did them partially.

I just want to clear up what you saw in the log that I sent.

The interesting thing I found out is that mpg TS Unprocessed on 2.3 is the same thing that mp4 Unprocessed uses on the new 2.5 although it might keep or convert it to h265 or h264. With 2.3 it seems to get rid of it if it is there.

I’m not clear as what you’re referring to. Is this is a different issue? Your original issue was dealing with why there’s a difference between 2.3 and 2.5 on how commercials are detected. That was resolved above, you need to disable ad marker extraction in 2.5 for your PlayOn recordings (2.3 doesn’t support PlayOn which is why it always ran Comskip and hence you had different results): MceBuddy 2.3.13 vs 2.5.4 - PlayOn AdSkip vs Comskip

I somehow missed that reply. I didn’t think I had a reply since I sent the logs. So to your point, when I checked just now I realized that the checkmark has always been there. But I can’t find the place where the explanation says that if this option is enabled you must make sure you enable the ad removal option in the conversion task settings.

  1. Can I just uncheck the box
  2. If I need the box checked I don’t see anything labeled the ad removal option in the conversion task settings.

So the box is checked and ComSkip is enabled and always has been and that is the closest thing I have seen to enabling the ad removal option

Sorry, I found the drop-down where it is set to Comskip and changed it to Use Markers. Hopefully that will fix it.

That did not work, but then the solution became clear once I understood what I was doing. I needed to uncheck the box and use ComSkip. That is because of the video. Playon handles the videos in two ways. It either asks me if I want to play it with adskip or in some cases it just starts playing it without adskip. With those videos, I need to use MceBuddy and Comskip to find the commercials and it found and removed all 5 commercial blocks. Thanks for your help which gave me the understanding of what I was trying to do.