Commercial handling not as expected - keeping existing


(Brian) #1

Hi. Commercial handling with a particular set of parameters is not working as I would have expected. Want to understand if this is the correct behavior.

  • I have a PlayOn MP4 file that has some existing (inaccurate) chapter information based on PlayOn commercial skipping.

  • My goal is to keep the file as is, but run ComSkip and apply the new chapters without going through the conversion process.

  • What’s actually happening in my scenario is that a new file is being created with the existing chapters and ComSkip is not (as far as I can see in the log) being run at all.

In my Conversion task I have:

  • MP4 Unprocessed as the Profile
  • Ad Remover: Yes (Comskip)
  • Only Detect Ads (I want to mark the ads not cut them)
  • Add Chapters is set to YES
  • Comskip information (like directory, etc.) are copied from other tasks that already work.

Here’s a log of what is happening, can I get help understanding this behavior and whether I have the wrong combination of options to do what I want to do?

Log with DEBUG:

Ink Master - s09e01 - Fire & Ice.mp4-Profile Test-2018-03-28T08-40-31.9434614-04-00.log (613.7 KB)

thanks,
BrianGGG


(Goose) #2

It’s not running Comskip because MCEBuddy found an existing EDL file along with the original video and it use that instead.

INFORMATION> 2018-03-28T08:40:54 MCEBuddy.Engine.ConversionJob --> Found existing EDL file and saved it

If you want it to run Comskip make sure there are no existing EDL/EDLP files with the original video


(Brian) #3

Thanks.

I’m confused by two things:

The help text for the help for Ad Markers is below:

image

This led me to believe that the EDL file would be used if I specified “Use Markers” and would run Comskip if I chose Comskip (I’m using the Yes (Comskip) option).

Also, in the target directory, the EDL file was moved … but it does not appear that the chapters in the EDL were applied (it still has the same chapters as the source). Shouldn’t the chapters from the EDL be applied to the target file in this situation?

thanks
BrianGGG


(Brian) #4

More information. I paused the conversion during the chapter/subtitle section and looked at the temporary files.
It appears that the EDL is being ignored and the existing chapters are being put back into the new file.

EDL File:

|0.97|74.04|3|
|839.54|942.61|3|
|1420.72|1524.69|3|
|2056.32|2138.67|3|
|2505.37|2598.43|3|
|2907.40|3041.97|3|

CHAP file:

CHAPTER01=00:00:00.000
CHAPTER01NAME=Chapter Video
CHAPTER02=00:00:14.674
CHAPTER02NAME=Chapter Advertisement
CHAPTER03=00:50:40.747
CHAPTER03NAME=Chapter Video

(Goose) #5

This would be a bug, if the EDL file exists and Only detect ad’s is checked, it should ignore any chapter files embedded in the file. Do open a bug ticket for it.

The other behavior is expected, when an EDL file is present it will always use it. When you select the use existing commercial markers option, it will only use existing markers.


(Goose) #6

Looking at this more carefully, in your instance this is actually expected behavior.
When using Comskip or ShowAnalyzer, MCEBuddy will first use any existing ad markers (EDL file or Chapter Ad markers). I’m guessing you’ve enabled the option to Check chapters for Ad markers in your conversion task expert settings, so in this case it’s extracting the ad markers from your file itself and using it. So that is working as expected, if you don’t want it to use your ad chapter markers then uncheck the option above.

There is a separate issue you’ve highlighted which I will look into see if that if actual chapters and EDL files exist then it should use the EDL file when only detecting ads instead of cutting them.

EDIT: I’ve checked it out and by design if there are chapter markers present it will use them first to preserve the chapters and if they don’t exist then it will convert the EDL file to chapter markers. So it’s working as designed but in your case you just need to turn off the option Check chapters for Ad markers in your conversion task expert settings


(Brian) #8

I checked the logfile to make sure that nothing changed.
The Ad Markers value was false when this problem occured, so in this particular instance I’m stuck and I’d like to put this in as a bug unless you think otherwise.

Search Ad markers from chapters -> False

This is a huge problem for me because I have a library full of PlayOn videos with existing Chapters that I will have to figure out how to get rid of if there is no MCEbuddy solution.

It’s highly possible that you will tell me “not as designed”, but here was my impression of the expected behavior for the various options that are relevant to this thread after reading the help text:

  • Ad Remover Dropdown:

NONE should leave any chapters alone in the source file and should take no action with ComSkip or an EDL file.

YES(USE MARKERS) Should use the existing chapters if the Check Chapters For Ad Markers checkbox is set, should use an existing EDL (if available) if Check Chapters for Ad Markers is not set

COMSKIP(YES) Should run ComSkip and apply the resulting chapters regardless of the existence of an EDL or existing Chapters.

All of these assume that the ADD CHAPTERS checkbox is set. If this checkbox is not set, then the resulting file should have no chapters at all (even if the source file has chapters)

Please let me know any thoughts on this.


(Goose) #9

If the Add chapters option is not set it should not add any chapters (commercial markers or otherwise).

But I do see a potential issue with PlayOn, even if you’ve set it not to Check capters for Ad markers, never the less there are “chapters” present, so while it process them as “ad markers” it will treat them like regular chapters.


[BUG] Check if chapters markers are advertisements markers and don't copy them if EDL markers are present
(Goose) #10

This should be fixed in today’s build.


(Brian) #11

Confirmed as fixed.
In my situation above, the resulting file uses EDL markers rather than keeping the existing Chapters from PlayOn.

THANKS!