Malformed TS files causing MediaInfo dll and MCEBuddy to crash

Burgers,.Brew.&.Que.S03E08.Beers, to MP4-2020-09-11T13-18-46.log (134.2 KB) mcebuddy.log (2.3 MB)

Attached are 2 log files. Last evening I noticed that conversions were not taking place. I have looked within the support emails and tried turning on mcebuddy thru services app in windows 10. The conversions begin but within seconds they stop. I tried restarting in services but this just repeats. I’ve not yet encountered any problems, this is my first. Please, need some help getting this fixed. Also, updated nvidia driver, but no change. Thanks in advance.

Windows is terminating MCEBuddy when it tried to load the DLLs and read your video file. This is a hard termination, i.e something catastrophic/unrecoverable happened within the OS (outside of MCEBuddy).

INFORMATION> 2020-09-11T13:19:01 MCEBuddy.VideoProperties.VideoInfo --> Reading MediaInfo from C:\Program Files\MCEBuddy2x\working0\Burgers,.Brew.&.Que.S03E08.Beers,

This usually points to a corrupted hard disk sector either where MCEBuddy is installed or where the video file is located.

If it’s happening with every video file, then the MCEBuddy installation hard disk sectors are corrupted.

Uninstall MCEBuddy (delete the directory after the uninstall), run a hard disk low level scan/repair and then reinstall MCEBuddy.

If it’s happening with one or a few video files only, then the hard disk sectors where those video files are located are corrupted.

Delete your video file or move it to a different hard disk (renaming/moving it to different folder on the same disk will not make any difference), run a hard disk low level scan/repair.

Thanks for the response. I have an SSD where mcebuddy is installed. All my conversions are read off a hard disk drive, separate from C; and no media data is ever on C, just the install of mcebuddy. I used performance monitor to run test on the ssd. Some of its response is similar to your explanation. Do you happen to know if there is a repair program which would also be healthy for the ssd? I am also uploading the performance report as best as I can.Performance Report - Sept 11 2020.docx (978.0 KB)

I uninstalled mcebuddy on C, then installed on an external hard drive. Within 30 to 45 seconds mcebuddy stopped converting. Is there any other way to get around this besides removing the present boot drive and then installing a new boot drive? Or maybe, could there be a problem with the external hard drive?

It sounds like your video file is sitting on a corrupted disk sector (since you’ve installed MCEBuddy on a new disk). See my post above on how to diagnose it.

So, I went to a 2nd pc and installed mcebuddy. I copied the recorded files and ran mcebuddy. The exact response as before happened. The files began to transcode but then stopped after about 30 seconds. It gave the same message as before, “The MCEBuddy service is unavailable. Please start from windows control panel or check engine connection.” I am uploading the log files. Thanks.Burgers,.Brew.&.Que.S03E08.Beers, to MP4-2020-09-21T20-54-08.log (134.2 KB) mcebuddy.log (5.6 MB)

Can you upload your original video file to our server for analysis. Instructions can be found here: Welcome to MCEBuddy - README BEFORE POSTING

I guess it took a good nights rest to get it right. I’m uploading now. Thank you.

1 Like

Thanks, there’s something in this file causing a third party DLL to corrupt the protected memory which in turn is causing Windows to terminate MCEBuddy. We’re looking into it, thanks for the sample. I’m moving this to bug status.

This has been fixed in today’s 2.5.5 BETA build. Please download it and try it out.

Got excited to hear there is a fix. I have installed the beta and it is running and converting as I send this message. Thank you very much. There are 53 files to convert. I’ll send results later.

All good. All files converted.