MCEBuddy no longer attempts to convert files

The past couple weeks, MCEBuddy has quit working for me. It constantly said the engine was not running. I uninstalled and reinstalled and had no improvement. I eventually did a clean install. Prior to that I went through the registry editor and removed any reference to MCEBuddy. I have tried installing the last 2 versions including the beta and get the same result. I have turned off my firewall and antivirus hoping maybe that was it, but still no improvement. Since the most recent changes, it will say it is running, but it doesn’t attempt to convert any files from the listed directory. Trying to add files manually doesn’t work either. (By the way, I use NextPVR for all my recordings).
Please help.
mcebuddy.log (1.5 MB)

The logs are showing that some program on your computer is locking the files so that hen MCEBuddy tries to access them windows is blocking the request.

WARNING> 2023-02-14T12:59:01 MCEBuddy.Engine.QueueManager → Monitor task Next PVR : Unable to queue file for conversion - file inaccessible/locked by another process F:\NextPVR Recordings\Impractical Jokers Inside Jokes\Season 01\Impractical.Jokers.Inside.Jokes.S01E17.DOOMED.ts

You’ll have figure out which program, it could be anti virus or some other monitoring software or a recorder software. Try disabling them one at a time till you figure out which one is the culprit. Maybe even try to reboot the computer.

It appears I finally found a solution. I noted the following on the log.

2023-02-14T12:55:06 MCEBuddy.Engine.QueueManager → File >The Three Stooges_20230211_17001720.ts<, checking filename filter >%ismovie%<Movies%showname% (%airyear%)%showname% (%airyear%),TV MKV Conversions%showname%\Season %season%##\S%season%##E%episode%##-%episodename% (%airyear%-%airmonth%-%airday%)><
WARNING> 2023-02-14T12:55:06 MCEBuddy.Engine.QueueManager → File The Three Stooges_20230211_17001720.ts did not match Filename meta data pattern

I noticed all the videos in the NextPVR folder had the same error message in the log.

I tried deleting all the file types listed in the search pattern box so it would convert all videos found but that did not work. So then I tried a new approach. I made new entries for the monitor locations and conversion tasks giving them a different name but chose the same settings as the previous ones. I then deleted the previous location entry and conversion task. Now everything is converting. Not sure why this would fix it unless somehow the files/registry settings associated with the configuration file had somehow become corrupted.

I had same issue and put recorded files in different folder and magically started working again. On one computer used as test machine, I cannot see any drives with mcebuddy or nextpvr so weird things happen. I have no idea how windows can see drives but applications cannot as they use os commands to access drives. I use nextpvr and it names the files with schedules direct data which I also pass to mcebuddy as xml file. If I rename files before converting, mcebuddy will note file name mismatch but still convert recording. The error looks similar to what you found. If you check logs regularly then you can catch things like poor quality recordings sooner so good to see that you read logs.