Just upgraded to 2.4.7 and getting "unstable Intel Display Driver" error

I just upgraded from an old free version to 2.4.7. Now I can’t convert recordings. (I followed the upgrade instructions to uninstall the previous version). I’m not trying to skip commercials yet, just converting wtv files to mp4. However, now I get this error message in the log.

ERROR> 2017-07-29T20:25:14 MCEBuddy.AppWrapper.Handbrake --> Hardware encoding appears to have hung, no progress in the last 0 seconds. This is likely due to an unstable Intel Display Driver. Try updating or using a stable Intel Display Driver. Terminating process.

I have Intel HD Graphics 530, driver I tried updating my driver. I also tried downgrading per the GPU/Hardware Encoding/Acceleration FAQs, but the drivers in that FAQ were not for Intel 530.

Can you direct me to a post with some solutions. I’ve looked through the discussions and searched the Knowledge Base, but may have missed it.


EDIT - I tried downgrading to 2.3.14 and it works. I am able to process videos. Maybe this will provide more info for a solution. Is there are newer version that will work with my graphics driver?

2.3.14 doesn’t use hardware encoding. It’s true you issue is the graphics driver, if the tried and tested versions don’t work you’ll just have to try other versions from Intel’s website until you find a version that does work. Please do post back if you find a version that works for your setup. Meanwhile just disable hardware encoding in your conversion task expert settings and it’ll solve your issue.

Also are you on the latest 2.4.8 BETA build? If not try it out and you may want to download the latest nightly build of handbrake and replace it in the install folder. That may also help.

Thanks for the response. I will try 2.4.8 and disable hardware encoding for now.

I will also try different drivers and report back.

1 Like

Try using today’s 2.4.8 BETA build. We added a new version of hand brake and introduced some optimizations which may help workaround some of these display driver issues.
Enable hardware encoding in your settings and give it a whirl.