Hardware Encoding with Intel QuickSync

#1

Hello all. I just joined the premium access program and need some help. I am converting a large number of WTV files saved with Windows MCE to MP4. I want to keep good quality, so I was expecting my conversions to be somewhat slow. However I am currently looking at approximately 7 hours to convert a 1 hour show with version 2.4.10 (down from 8 hours that 2.3.13 used to take)
I think I am not taking advantage of HW acceleration properly. It appears that I am using QuickSync from my CPU, but it is a low end processor. So I was hoping I could use the graphics card to speed things up. I don’t think the card is being used at all. This is my configuration:
ASRock B150M Pro4S / Intel Celeron G3900 / 8GB RAM / AMD Radeon RX 470 4GB
Here is a sample log file:
Blindspot_KNTVHD_2019_01_11_19_58_00.wtv-Convert to MP4-2019-04-18T03-53-59.2182815-07-00.log (3.9 MB)
I would appreciate any tips on how to optimize my conversion.

(Goose) #2

MCEBuddy detects your Intel QuickSync capabilities and starts out by using hardware encoding but then your graphics driver hangs and MCEBuddy needs to revert to software encoding.

MCEBuddy.AppWrapper.Handbrake --> Hardware encoding appears to have hung, no progress in the last 300 seconds. This is likely due to an unstable Intel Display Driver. Try updating or using a stable Intel Display Driver.

This is the most common issue with hardware encoding (it’s done by the graphics drivers). Try using one of the tested/recommended graphics driver version which is more stable for hardware encoding: GPU/Hardware Encoding/Acceleration FAQs

#3

Thanks for the response. I just tried again with different drivers suggested in that page and keep getting an error message “This computer does not meet the minimum requirements for installing the software.” Just wondering if the graphics card is disabling the onboard GPU. I’m going to try disabling and see what happens.

#4

OK. My solution was to shutdown the computer and connect the monitor to the onboard HDMI input instead of the graphics card. Those errors are gone from the logs and now I am down to 70 minutes approximately; much better. Is this all I can do? Is the limitation the CPU? Can I somehow take advantage of the graphics card?

(Goose) #5

It sounds like you used the fake monitor trick (search the forum) to force your motherboard and windows to disable your graphics card.
You can try using the Microsoft driver from windows update for your graphics card or try downloading the graphics drivers from your manufactures website or manage one from the intel website. Intel drivers are notoriously unstable. You’ll just have to experiment until you find one that’s stable and works well for hardware encoding.