QuickSync detected, not used. Secondary AMD card


(Jeremy Seitz) #1

I’ve read and read… any help is appreciated. Trying to get Quicksync to work on my unused GPU.

i7 8700k win 10 64bit
AMD Radeon HD 6700 video card, two monitors
No monitor plugged into the motherboard port. Intel Display adapter grayed out in device manager. I don’t totally understand why there are two adapters, a 4000 (driver 10.18.10.4358) and 630 (driver 25.20.100.6326).

INFORMATION> 2018-10-30T06:55:56 MCEBuddy.AppWrapper.Handbrake --> QuickSync encoding support available -> True
INFORMATION> 2018-10-30T06:55:56 MCEBuddy.AppWrapper.Handbrake --> H.264 encoding support available -> True
INFORMATION> 2018-10-30T06:55:56 MCEBuddy.AppWrapper.Handbrake --> H.265 encoding support available -> False
INFORMATION> 2018-10-30T06:55:56 MCEBuddy.Transcode.Convert --> Converting with Handbrake

But doesn’t show that it is using QS.

The Big Bang Theory (2007) - S01E06 - The Middle Earth Paradigm.ts-Comskip-2018-10-30T06-54-56.8568007-04-00.log (26.6 KB)

Steps taken:

  1. Updated intel drivers to those on the MCEBuddy webpage

  2. Can’t do the ‘monitor trick’ (windows 10 gui not the same). Incidentally, if I plug in a monitor, QuickSync is not detected.

  3. Updated Handbrake CLI to 1.1.2.
    INFORMATION> --> Total time taken by conversion (hh:mm:ss) -> 00:01:23


(Goose) #2

You may want to set your logs to debug in the system settings page to see more details about what’s being used.

At the outset MCEBuddy detects that quicksync is available. I can’t see anything else in these logs without it being to set to debug but likely it’s using it.

MCEBuddy.AppWrapper.Handbrake --> QuickSync encoding support available -> True INFORMATION> 2018-10-30T06:55:49 MCEBuddy.AppWrapper.Handbrake --> H.264 encoding support available -> True INFORMATION> 2018-10-30T06:55:49 MCEBuddy.AppWrapper.Handbrake --> H.265 encoding support available -> False


(Jeremy Seitz) #3

Goose - thanks for the help!

Ok, so I suppose that could be correct… I turned on Debug, and ran it with and without Hardware encoding. Sure looks in the log like Quick Sync is still used when I turned off Hardware encoding (in MCEBuddy). But I can’t really figure half of what is in the log.

Also curious:
No Hardware --> Didn’t look at CPU, 230 then 130 fps, total time 22 min
Quick Sync --> ~83% CPU, both passes avg 55 fps, total time 50+ min
Quick Sync seems to provide slightly better quality.

So, clearly I should turn off h/w encoding. Any advice? Any explanation?

NO hw encoader (2013) - S06E06 - Fiddler.ts-Comskip-2018-10-31T22-20-44.6719701-04-00.log (1.8 MB)

W hw (2013) - S06E06 - Fiddler.ts-Comskip-2018-11-01T20-27-45.6390554-04-00.log (3.9 MB)


(Goose) #4

With hardware encoding disabled it’s using the software encoder and running at an average of 128fps
With hardware encoding it’s using your quick sync encoder and running at about 52fps.
There are a couple of reasons why this usually happens

  1. Your graphics driver isn’t optimized for encoding. Try using one of the recommended versions (see Graphics FAQ) which are stable and encoding optimized versions
  2. You’re using the MKV High Quality profile which has many advanced encoding features enabled. It’s possible that your driver / hardware isn’t efficient with these advanced features. You can try using the Normal or fast profile.

Intel cards usually work between 120 and 600fps, so I am thinking option 1.