EDL files not moving back

I have a basic requirement for MCEBuddy to scan my files and just create an EDL file. No cutting or anything just scan and create the file.

Now, I have this “working” but it has an odd quirk that I cannot figure out. If I start the conversion task manually it 100% of the time creates the EDL file and copies it back to the required folder. However if it runs automatically it does not always do so but selecting “reconvert” from the history always sorts it.

Does anyone have any ideas?

I have attached two logs both seem to show it finding and moving the EDL file but it was only there after the working one which was a “reconvert/manual” run.

Working_Taskmaster2021-04-29-S11E07-Channel 4 HD.ts-converted-2021-04-30T18-13-32.log (285.9 KB) Failed_Taskmaster2021-04-29-S11E07-Channel 4 HD.ts-converted-2021-04-30T00-12-01.log (314.0 KB)

Thanks in advance

One thing I have just changed (after posting this) is the service now runs as my user account just incase it was that. However I do have the UNC creds in the app and it does work on a manual run but its worth a shot.

Unfortunately this is still a problem. I have upgraded to 2.5.6 too but no change, still as per my original post. Anyone have any ideas/things to try?

Anyone have any ideas at all? I can still see in new conversions that it has created the EDL file then moves it but the file is not in the destination folder. Pressing “reconvert files” runs the process again and it works 100% of the time.

If I understood your issue, the EDL file isn’t being copied to the destination folder, is that correct?

Your logs show that the converted file and EDL file is being copied and I don’t see any errors so if it’s doesn’t show up it’s possible that it’s a network issue or something at the destination deleting it. Have you tried using a local drive as the destination?

Following on from the suggestion above about something deleting the files I have done some investigating. I enabled the recycle bin feature on my NAS so that I could see if a file was being deleted and indeed it was. Then followed a few days of testing different things that could be doing it. Turns out because I had Plex enabled to remove commercials too (I watch back on either Kodi or Plex) it was removing the EDL file once it had finished it search. This explains why every time I ran MCEBuddy manually it would work as I would always be running it after Plex had ran! I have disabled Plex searching now which is a shame but luckily I don’t use it much.

Many thanks for the suggestion which helped me resolve this.

1 Like