Custom Cut -> MCEBuddy starts/ends in wrong places

I record .TS files on my Plex DVR and then bring them into Custom Cut and manually mark the start/end of each commercial break. I save the EDL file and then send it over to MCEBuddy for Convert to MP4 and the generated video NEVER gets the start/end points right for any commercials. I’ve finally figured out via experimentation that the time sync between the video scrubber in Custom Cut and the times it calculates for start and end points when you mark are way off. I might be at 20:07.123 according to the scrubber but the same video when played in any other video player I have identifies that spot as 18:12.345 or something. The inconsistency is seemingly random, off by anywhere from a minute or more to seconds, but no matter how you look at it, the Custom Cut app is broken on my system. I mostly record old movies and I can live with manually marking start/end because I trust the result more than comskip, but the basic one thing the app is intended for simply doesn’t work.

1 Like

You may want to Google custom comskip mcebuddy.
The comskip file that comes with mcebuddy isn’t the best, but the one in Plex is pretty good at removing commercials.

This doesn’t have anything to do with Comskip.

This is the workflow:

  • Open a video file in Custom Cuts (no comskip)
  • Manually navigate to the commercial start point, insert start marker
  • Manually navigate to the commercial end point, insert end marker
  • Send to MCEBuddy for commercial removal (no comskip, use markers)

The start/end markers are always off by anywhere from a few seconds to a minute or more. The video displayed in the playback window in Custom Cuts is NOT in sync with the time code for the video, therefore all the start/end points are wrong. I can prove this by opening the exact same video in avidemux and navigating to the exact same commercial start/end points and comparing the times. Avidemux will show the correct time and I can then copy/paste those corrected times into Custom Cuts. If I do that, the resulting .edl file is correct and MCEBuddy can remove the commercial successfully. Basically, Custom Cuts works as an EDL editor but not as a video previewer for finding/validating the edit points. I have tried this on two different PCs and the behavior is consistent.

That is strange. I haven’t had any issues using Custom Cuts to create EDL files. It sounds like a bug. Something related to your source file it isn’t reading the same as other files. I recommend putting in a bug and making the source file you have available if able.

At the bottom of this post gives details for uploading files.

This happens with all .TS files I record via Plex so I can definitely provide a source file. They are all MPEG2VIDEO files, Windows 10, using Hauppauge WinTV tuner, nVidia video card, not unusual setup. Recording OTA television broadcasts. I’ll find a smallish source file to upload and file a bug. Thanks!

Yeah, sounds like a pretty normal setup.

I use somewhat of the same setup except I use Plex DVR to record my cable via a HDHomerun. I use the Plex to remove commercials but when I have used Custom Cut on my TS files I have not experienced that. It cuts the file exactly where I mark it with Custom Cut. If you have a small TS file to share I could try it on my setup and see if it does it with mine as well?

1 Like

Just posting in here to say that I was having a separate issue with the cuts from MCEBuddy from comskip being off that I tried using Custom Cuts, and I was having the same issue as well - the EDL was way off.

Makes me wonder if its something to do with the way Plex records and MCEBuddy processes those that is causing the cutpoints to be off.