MCEBuddy skipping commercial cuts set by Custom Cuts

customcuts
commonissues
#1

I used to use the function all the time, but just re-installed MCEBuddy again and tried to use the Custom Cuts feature. The first attempt I went and cut out a section at the beginning and a section at the end. I ran it after saving the EDL but when I opened the converted file nothing was cut!
I changed a setting in the Conversion Task -> Ad Remover -> Yes, Use Markers
Ran it again, and it cut off the end but not the beginning
Is there some other setting I need to tweak?

Thanks!

0 Likes

(Goose) #2

Sounds about right, attach the conversion log so we can see what’s going on.

0 Likes

#3

MCEBuddy.txt (623.0 KB)

The original log was MASSIVE (couldn’t even upload it) so I went through and removed hundreds of lines that looked like they were very similar to one another. Hope I didn’t cut something out that you needed to see, but let me know if you see anything with the attached, thank you so much for your help

On a similar note to this, is there a setting that I can change that will allow the custom cuts to start/stop EXACTLY where I place them? I’ve found that there is always some kind of small buffer that varies from a few milliseconds up to two seconds. Which when I’m clipping out specific sections of commercials is tough because I cut it when the screen goes black before the show starts, and when it’s done I’ve missed a little bit of the show starting. Not sure if that makes sense

0 Likes

(Goose) #4

Your conversion task settings are set to not commercial commercials.

Commercial Removal -> None

The cutting happens along boundary frames in mpeg4 otherwise you’ll have “tearing” video. That’s how mpeg4 works. The more I frames your original video contains the more accurate the cuts will be.

0 Likes

#5

Hmmm, I have the Ad Remover set to Yes (Use Markers) so I’m not really sure what is turned off? This setting worked with cutting the “second cut” but not the first. When I had it set to Yes (Comskip) nothing was cut at all. Again, this is all using the Custom Cut feature

0 Likes

(Goose) #6

Something weird going on. The logs show it’s disabled which is why it’s not cutting. Try to uninstall and reinstall MCEBuddy and this time download the latest 2.4.10 beta. You may need to recreate your conversion task and see if that helps.

0 Likes

#7

Okay, uninstalled MCEBuddy and then reinstalled the beta. I ran it with the existing conversion task and got the same results, so I created a new conversion task and deleted the old one. Ran it again, and same thing: not making the first cut but it does make second cut. Bizarre to me that it makes one cut but not the other…
Anything else I can try?

0 Likes

(Goose) #8

Help me understand this, what’s the first cut and second cut. Can you attach the log files for both so I can compare.

0 Likes

#9

Victor and Valentino_TOONPHD_2019_03_30_17_00_00.wtv-MKV 1080-2019-04-03T22-57-08.7884221-07-00.log (1.5 MB)
Victor and Valentino_TOONPHD_2019_03_30_17_00_00.wtv-MKV New-2019-04-04T08-15-26.9524066-07-00.log (1.3 MB)
Here are the two logs.
First cut is from 0:00 to 0:11 which is to remove the “intro commercial” so the converted video starts right at the beginning of the show. The second cut starts right when the show ends and removes all of the leftover commercials and previews at the end

0 Likes

(Goose) #10

MCEBuddy won’t make cuts less than 20 seconds (by default, you can adjust this as show below). This is due to a limitation of the underlying encoders which can cause the process to fail if the cuts are too small (due to lack of I frames). So keeping that in mind, I see this in your logs which sounds about right to me:

2019-04-03T22:57:42 MCEBuddy.CommercialScan.Scanner --> Testing EDL File Validity
2019-04-03T22:57:42 MCEBuddy.CommercialScan.Scanner --> ParseEDL: Cut Segment Start:0.000 End:11.593 Action:0
2019-04-03T22:57:42 MCEBuddy.CommercialScan.Scanner --> ParseEDL: Cut Segment Start:672.715 End:897.404 Action:0
–> ConvertCutListToKeepList: Skip initial segment, too small Start:0.000 Stop:0.000
–> ConvertCutListToKeepList: Keep segment Start:11.593 Stop:672.715
–> ConvertCutListToKeepList: Keep end segment Start:897.404 Stop:898.477
–> ConvertKeepListToCutList: Skip segment, too small Start:0.000 Stop:11.593
–> ConvertKeepListToCutList: Cut segment Start:672.715 Stop:897.404
–> ConvertKeepListToCutList: Skip end segment, too small Start:898.477 Stop:898.477
–> ConvertKeepListToCutList Done

So it skips the first but cuts the second.

In your second file both cuts are larger than 20 seconds so it works fine:

2019-04-04T08:16:00 MCEBuddy.CommercialScan.Scanner --> Testing EDL File Validity
2019-04-04T08:16:00 MCEBuddy.CommercialScan.Scanner --> ParseEDL: Cut Segment Start:0.000 End:11.659 Action:0
2019-04-04T08:16:00 MCEBuddy.CommercialScan.Scanner --> ParseEDL: Cut Segment Start:672.712 End:898.000 Action:0
–> ConvertCutListToKeepList: Skip initial segment, too small Start:0.000 Stop:0.000
–> ConvertCutListToKeepList: Keep segment Start:11.659 Stop:672.712
–> ConvertCutListToKeepList: Keep end segment Start:898.000 Stop:898.477
–> ConvertKeepListToCutList: Skip segment, too small Start:0.000 Stop:11.659
–> ConvertKeepListToCutList: Cut segment Start:672.712 Stop:898.000
–> ConvertKeepListToCutList: Skip end segment, too small Start:898.477 Stop:898.477
–> ConvertKeepListToCutList Done

Having said that, if you want you can reduce that 20 seconds down to 0 or any number you want from the System Settings page, YMMV. We set that number based on the recording samples we have from over 100+ countries and thousands of channels, but you can always customize it to what works for you. Just keep in mind that if the cuts start failing it may be because the segments are too small.

0 Likes