Confirming hardware encoding is working?


#1

I just setup MCB and it takes about 40 minutes on my i5 3350P and 1050 TI GPU with 16GB RAM, want to confirm if everything is working properly or is there room for improvements? 40 minutes seems kinda long, an old core2duo processes the same file in 1 hour with just software decoding.

Seems to use mencoder instead of handbrake or ffmpeg is that correct for my Nvidia card?

Log here

Seem like it is working based on this


(Goose) #2

Yes it’s using hardware encoding of your CUDA card. The performance summary at the end shows your conversion took just under 30 minutes:

|--> <Start At Date/Time>|<Duration (hh:mm:ss)>||<Activity>|
|---|---|---|---|
|--> <10/04/2018 11:40:52>|<00:00:00>||<Running custom commands>|
|--> <10/04/2018 11:40:52>|<00:00:00>||<Getting show information and banner from Internet sources>|
|--> <10/04/2018 11:40:52>|<00:00:00>||<Running custom commands>|
|--> <10/04/2018 11:40:52>|<00:00:02>||<Checking for disk space>|
|--> <10/04/2018 11:40:55>|<00:02:11>||<Copying source file to working directory>|
|--> <10/04/2018 11:43:07>|<00:00:00>||<Trimming video recording>|
|--> <10/04/2018 11:43:07>|<00:00:15>||<Analyzing video information>|
|--> <10/04/2018 11:43:22>|<00:00:00>||<Advertisement scan>|
|--> <10/04/2018 11:43:22>|<00:00:00>||<Running custom commands>|
|--> <10/04/2018 11:43:22>|<00:02:47>||<Removing commercials>|
|--> <10/04/2018 11:46:09>|<00:00:17>||<Analyzing video information>|
|--> <10/04/2018 11:46:27>|<00:02:02>||<Analyzing video information>|
|--> <10/04/2018 11:48:30>|<00:29:55>||<Converting>|
|--> <10/04/2018 12:18:26>|<00:00:05>||<Writing show information>|
|--> <10/04/2018 12:18:31>|<00:00:00>||<Renaming file using show information>|
|--> <10/04/2018 12:18:31>|<00:00:00>||<Running custom commands>|
|--> <10/04/2018 12:18:31>|<00:00:13>||<Moving converted file to destination>|
|--> <10/04/2018 12:18:45>|<00:00:00>||<Running custom commands>|
|--> <10/04/2018 12:18:45>|<00:00:00>||<Success - All done!>|

It’s showing that your graphics card is converting at 54fps, that’s a little slower than what most folks may get (between 120 to 240fps). The speed depends on your graphics card/driver and the conversion options. Try a couple of things:

  1. Change your graphics driver (some perform better than others)
  2. Change some conversion options, try to disable Cropping (detecting black bars) in your Conversion Task -> Expert settings. Some graphics card slow down while trying to crop and convert.

You can dig very deep down by trying to optimize your ffmpeg profile to match your cards capabilities.


#3

I had 391.24 drivers prior and it finished a minute faster than this test and am now using the latest released drivers from Nvidia. I haven’t yet tried the recommended drivers as I would like to keep it as current as possible since this is my gaming rig as well at the moment.

will check out cropping, these shows don’t have black bars so it makes sense to disable it.

Also why is it using Mencoder instead of handbrake? as i understand ffmpeg is Intel and handbrake should be nvidia

I’m running test 3 and noticing 70% usage on cpu and only 6% on GPU.

EDIT:

Installed the recommended Win10 CUDA drivers 376.51 (just drivers no cuda stuff) and now i’m getting 32fps vs 54fps with 416.16

EDIT2: Uninstalled all my drivers including ones downloaded by Windows Update and performed a clean install, conversion time is now down to ~33 minutes and about 55fps, probably within margin of error.

It is safe to say Nvidia drivers 416.16 are working better than the previously recommended Cuda drivers.


(Goose) #4

Ffmpeg for NVidia CUDA and Handrake for Intel QSV. The rest are just auxiliary tools.

You can also experiment with your ffmpeg profile and see which options may be slowing down your card. Disable the post processing filters or try a different ffmpeg profile.

@Will_Tschumy is the guy for MCEBuddy and NVidia