Cannot connect remote client to server

2.4.7 is LAST version I can get that allows remote client on win10 to connect to server on win7.
the server end works fine even on last beta version, however remote client on win10 (bld 1809) machine only works with 2.4.7. so fo course have to run older version on server.
issue is client side only, on domain (I am admin) all firewall ports are opened.
on 2.4.7 when you enter remote info (ip or name) system either connects or shows version mismatch issue, all later versions do NOT save the remote client info so on every start it defaults to local host. been trying for some time, first time reporting. today tried latest stable and latest beta, same issue,
there a file I can edit somewhere to manually input the remote server info?

EDIT: on win10 remote end I did edit the C:\Users\Public\Documents\mcebuddy file to make sure it was using correct remote client info. It was set correctly,

The remote client and engine must be running the same version of MCEBuddy.

Assuming your firewall ports are opened (BTW MCEBuddy does that for you if you’ve checked Enable remote access in the System Settings page), check the port on the server side using the server side client.

On the remote client side click the Engine button to match the IP address / port of the server engine.


If the MCEBuddy version matches on both ends (engine and client) it should work fine.

thats all been checked and 2.4.7 works client and server.
just remote on win10 end on newer version sis issue. going to install newest release client on another win7 machine later today if newest versions (server and remote) work win7 ro win7 need to look at the win10 remote client to win7 server setup.

yup win 7 to win7 works on 2.5.4 and 2.5.5beta.
need to investigate the win10 side, will install remote on another wim10 machine to see if its issue with one pc only.

yup win10 1809 is not saving the remote server info in gui. the C:\Users\Public\Documents\mcebuddy file DOES show correct remote server info gui does not reflect it.
screenshots showing me entering info in gui, shot of gui not showing changes, shot of the mcebuddy file showing correct server info

mce2 mce1

sorry to post so much, but last edit was large and did not want this info to get hidden in it.
it really seems to be win10 1809 issue. installing server on another win10 1809 machine using mce 2.5.4 on both machines and remote not working. cannot find any logs either.
basically win10 1809 is not saving any remote server info

edit: just noticed when I uninstall that mcebuddy file was not deleted. manually deleted and reinstalled file NOT created.

That’s because the file isn’t used. Only use the client to change the settings instead of manually editing the files.

yeah thats what I figured. so we’re back to this. win 10 1809 remote server not getting saved.
tested on pc that had never had mcebuddy installed.
2.4.7 works fine.
will have to forego remote client I guess and just rdp into server when needed.

It’s working here. Use an IP address instead of DNS names in the remote client. Disable your Windows firewall on the server and the remote client machine and then try it. If that works then you know it’s a firewall issue.

already did that.
its not so much its not connecting as it is that when entering info hit ok client restarts like it should and then its right back at localserver
on these 2 1809 pro (on domain) machines setting not getting saved. tried compatibility settings/admin installs too, no luck.
2.4.7 different story, cannot see whats different in underlying parts to know why.

ok heres an oddity.
if I install FULL version on these 2 win10 machines I CAN connect to the remote server.

Here’s a tip, don’t “install” the Remote Client, just extract it from the zip file into a folder and run MCEBuddy.GUI.exe. This way you can actually have multiple remote clients running at the same time on the same machine from different folders, each with their own configuration.

ok running that does allow me to connect to server.
installing does not.
i can uninstall full version (by that I mean the full actual program not just the client) and just point a shortcut to the gui.
it seems to save the desired server which is good.
still odd installing the remote client did not work while this and installing full converter program did work.

EDIT: just noticed add button greyed out on these and also on the full version installed on this machine, again 2.4.7 no issues.
something on these 2 machines causing it, will just rdp to server when needed.