Connecting MCEBuddy Viewer to a remote engine

documentation
#1

I have installed MCE Buddy viewer, and configured MCE buddy for remote control however, I haven’t setup any firewall rules, etc. I cannot get MCE Buddy viewer to recognize my instance of MCE Buddy on my remote machine. Has anyone had any experience making this work? Thanks.

0 Likes

(Goose) #2

By default MCEBuddy Viewer will assume that the engine is installed on the local machine. If you want it to connect to a remote machine here what I think needs to be done:

On the machine where you’ve installed the MCEBuddyViewer, you’ll have a create to a file called mcebuddy (with no extension) in the directory %PUBLIC% which is typically C:\Users\Public so it’ll look like:
C:\Users\Public\mcebuddy

Open the file using Notepad, paste this information and save it:

[Engine]
RemoteServerName=192.168.1.245
RemoteServerPort=23332

Replace the IP address with the IP address or name of your remote machine that’s running the MCEBuddy engine (and the port if you’re using a custom port).

Then restart the MCEBuddy Viewer

0 Likes

(Goose) pinned #3
0 Likes

#4

I performed the suggested steps but my MCE Buddy viewer instance still isn’t connecting to the remote MCE Buddy. I checked that firewall rules were configured and they were. I tried just disabling the firewall on the MCE Buddy machine but I still could not get a connection. Is there anything else I can try?

0 Likes

(Goose) #5

I think it’s the location of the folder where you put the file, it varies by OS. What OS are you using?

0 Likes

#6

Windows 7. Thanks.

0 Likes

(Goose) #7

So you’ve tried using the directory:
C:\Users\Public

Can you try using the directory:
C:\Users\Public\Documents

Also can you post the mcebuddy file you’re placing in that folder?

You may need to restart the machine after doing this or atleast restart Media Center.

0 Likes

#8

I moved the file to documents but I get the same results. Here is what the file looks like

[Engine]
RemoteServerName=192.168.29.200
RemoteServerPort=23332
0 Likes

(Goose) #9

Okay the contents look okay.

Couple of things to check:

  1. Disable the windows firewall on both machines for testing purpose (MCEBuddy engine and MCE)
  2. Install the MCEBuddy Remote Client on the Windows Media Center machine, then try to connect to the remote engine by clicking on the engine icon on the bottom left corner of the screen. First confirm that the remote client is able to connect to the engine. If not then you’ve got a communication/network issue somewhere
  3. Once the remote client works, then try placing the mcebuddy file you created above in the following directories
  • C:\Users\Public
  • C:\Users\Public\Documents
  • C:\ProgramData

After each change you should reboot your machine for the changes to take effect

0 Likes

(Randy) #10

I’m having a very similar issue. No matter what I try, the remote client always reverts back to localhost after I change it.

0 Likes

(Goose) #11

Where did you install the remote client? It sounds like it doesn’t have permission to write you new settings back to the file where it’s installed. This is completely different from the issue above. Make sure your installation folder has write permissions for everyone and it should fix your issue.

0 Likes

(Randy) #12

I just accepted all the defaults during installation. I’ll check and see what I find.

0 Likes

#13

Is the MCEBuddy Remote client a separate application from MCE Buddy Viewer or is it installed with MCEBuddy viewer?
If its completely different then that might explain my troubles.

0 Likes

(Goose) #14

Separate. The remote client is available on the premium access server.
The viewer is a third party plugin for WMC that was developed by someone else.

0 Likes