Changing Remote Client engine name throws version mismatch message

(Dave B) #1

I’ve been running MCEB for years - am having trouble reconnecting Remote Client. Seems like this has been happening since 2.4.9 but have been able to use a 2.4.7 remote with newer releases, but with 2.4.11 the older remote client reports a version mismatch and quits.

On the remote side when I try to change the Engine from localhost to the machine which MCEB is running, I’ll click on OK and the engine reverts back to localhost. Everything is set up on the main engine.

(RBoy) #2

You need to ensure the engine and remote client are on the same version.

If you’ve updated your engine to 2.4.11 then you need to update the remote clients to 2.4.11 as well.
We added this check in the last few releases to ensure compatibility between the clients and engine with each release.

The good news is that upgrading the remote clients is a one step operation, just extract the ZIP file contents of the latest remote clients release to overwrite the existing remote client files and you’re done.

(Dave B) #3

I have the same version on both the main engine and the remote

1 Like
(RBoy) #5

The issue you’re facing sounds like it isn’t able to save the settings you’ve changed. Check 2 things:

  1. There is a directory called config where your remote client is installed/extracted
  2. MCEBuddy has write permissions to that directory (if you’re not sure, set the write permissions to everyone for the config directory)

It isn’t able to save the settings you’ve entering to a file called temp in the config directory which is why it’s falling back to the default localhost.

Also check that the ports are open (default 23332) on the machine where the engine is installed, assuming you’re done this already.

If you’re seeing a version mismatch and the engine is localhost, then means there is a mcebuddy engine installed on the local machine and it’s version doesn’t match the version of the remote client on the same machine.

(Dave B) #6

Sorry for the confusion - what I was trying to say was that I haven’t been able to connect like versions of MCEB & remote since (I think) 2.4.9 but was able to use the remote for 2.4.7 as a work around - did not report version mismatch.

With the current release with I can’t use the work around - but still cannot connect same version of MCEB & remote.

I’m running the install and changing the target engine from an Administrator account - the protections are ok on the config directory and temp file (which is empty). I don’t get any error when I change the remote to the host for the engine - screen just clears and relaunches the Welcome screen, no changes made.

(RBoy) #7

Yes that’s the indication that the settings weren’t saved. After 2.4.7 the settings were saved locally in the directory config folder. Earlier it used to be saved in a common temp directory but one couldn’t connect to multiple remote engines with that setup so we changed it to storing it locally, that way you can connect to multiple remote engines.

If the settings were saved then you’ll see the new settings when it starts. You can confirm this by opening the config directory and you’ll see a file called temp. Open it and you should see the new settings, if not then it may be corrupted or have a permission issue. Try to delete the temp file and check the permissions of the config folder.

(Dave B) #8

I deleted the temp file and no new file was created - also tried deleting config folder same results, recreated folder - nothing

Can I make a manual entry in the temp file ?

(RBoy) #9

That would indicate a filesystem/permissions issue. It would be simpler to just delete the folder and extract the Remote Client zip into a new folder and ensure it’s permissions are set to Everyone read/write/modify.

I just did a quick test here, extracted the ZIP file into a folder on my desktop into a new folder, started MCEBuddy.GUI and changed the remote engine IP and it worked fine.

(Dave B) #10

Ok that worked - but created a file named tempsettings and had the entries for [Version] and [Engine] moved it to the actual installed location and the Remote starts pointing to the proper place.

Thank you.