Engine Core Problem


(Don Exum) #1

When I run MCEBuddy, It says to check and see if the engine is running. I stopped and restarted several times with no results. I tried reloading twice and have the same problem. I don’t know what to do next. Here is what is in the event log.

Error 24-Jul-2017 11:33 PM
Unable to complete initialization of MCEBuddy Engine Core.
Error: System.InvalidOperationException: This access control list is not in canonical form and therefore cannot be modified.
at System.Security.AccessControl.CommonAcl.ThrowIfNotCanonical()
at System.Security.AccessControl.CommonAcl.AddQualifiedAce(SecurityIdentifier sid, AceQualifier qualifier, Int32 accessMask, AceFlags flags, ObjectAceFlags objectFlags, Guid objectType, Guid inheritedObjectType)
at System.Security.AccessControl.DiscretionaryAcl.AddAccess(AccessControlType accessType, SecurityIdentifier sid, Int32 accessMask, InheritanceFlags inheritanceFlags, PropagationFlags propagationFlags)
at System.Security.AccessControl.CommonObjectSecurity.ModifyAccess(AccessControlModification modification, AccessRule rule, Boolean& modified)
at System.Security.AccessControl.CommonObjectSecurity.AddAccessRule(AccessRule rule)
at MCEBuddy.Engine.Core.CreateExposedDirectory(String dirPath)
at MCEBuddy.Engine.Core…ctor()


(RBoy) #2

Did you go through this troubleshooting guide? This error indicates a corrupted install with insufficient permissions.


(Don Exum) #3

Thanks a lot. I think that solved it. Working GREAT.