MCEBuddy service failed to start

Was working, but this morning I have this error message come up when I tried to open MCEBuddy. This is the latest donator version installed about a week ago after uninstalling the previous version. All of that went fine until this morning.

Also, don’t seem to see an email address to contact support. I may have one from a few years back in my e-mail archives, but thought I’d post here as well.

Any helps appreciated.


Try starting it from the Control Panel -> View local services - > MCEBuddy2x

If it’s still not starting, open Control Panel -> View Event Logs -> Windows Logs -> Application

Or you can click on the Events button on the MCEBuddy application page, top right and it’ll show you the events log from Windows.

Looks for logs from MCEBuddy2x as the source and see what they say, it’ll tell you why it’s failing to start the service. Could be a corrupted file.

Tried all of the above. Looking at the logs does not help here as they appear to be conflicts within this system and MCEBuddy. Not something fixable unless there is something I can uninstall/resinstall. I have done just that twice now. Did and uninstall /reboot/reinstall, no help. Did a uninstall/reboot/reinstall previous version before I did this update a week or so ago, no help. It must have something to do with windows supporting software not dealing well with MCEBuddy now. Can I get you the log file or something else that can help you find this problem? I am looking at the MCEBUddy Windows Event Log Viewer now and it has 177 Entries from 7-Aug-2017 to 11-Aug-2017. Not sure why then only go back that far, but seems like much is missing. I ran system file checker (SFC /scannow) and there are no problems with windows files that came up. Since I did uninstalls and reinstalls of MCEBuddy, what is left? Only thing I can think of is conflicts among other software somehow.



I see what might be the problem and also why log entries start at 7-Aug-2017. This computer has done an upgrade to version 1703 of Windows 10. It was version 1607. Has MCEBuddy been tested using this new version 1703 of Windows 10?


Yes it’s working fine. However the “windows creator” update of windows 10 creates firewalls entries to block local programs. No idea why Microsoft did that but then again who know what Microsoft does.

Do a clean install and also try to disable the windows firewall or create an exception for mcebuddy in the firewall. You could try to enable firewall exception check box in the mcebuddy system settings page and see if that does the firewall trick.

I am using Norton Security and it takes control of Windows 10 firewall. I did an uninstall of mcebuddy, rebooted and disabled firewall rules (turned it off) in Norton Security for 15 minutes. Reinstalled mcebuddy and opened mcebuddy and it still is not connecting to mcebuddy service, even though the service is on. I then closed mcebuddy.gui.exe and went into task manager and ended tasks on mcebuddy service. Ran mcebuddy 2x commandline service and still did not work. I did a screen grab of this and am including it. Perhaps something in it will tell you where I should look further into this. One thing I have a question on, is localhost. I presume this is the “engine connection” mentioned in red on the mcebuddy status - not connected window. If so, could there be a conflict with the default port? I tried assigning a different port address using the small icon tic on the mcebuddy window, but that made no difference. Do I need to change this in the mcebuddy.conf file as well or does it change automatically when I change it in the mcebuddy window. There must be some method available to trace this issue isn’t there?



The canonical form exception means your fileystem is corrupted and hence it’s preventing MCEBuddy from starting. See the installation issues FAQ, the point on Canonical exception and follow the instructions.

Thanks for the leads. Although I had done many uninstalls and reinstalls, I hadn’t deleted the directorywhere mcebuddy resided before. As I have a very extensive configuration setup, which I keep backed up, I decided to give that a try. That worked, so there must have been something in the directory that was indeed corrupted somehow. Put my configuration backup in the newly recreated directory/sub-directory after the install and all is well.

The only question that remains is, what was corrupted and why?

I guess I don’t need to know that, but I suppose it might be helpful in some ways if we did know.

Thanks again.