Service not starting after reinstall


(Rob) #1

I installed an earlier version by accident had trouble removing the software and deleted the HKEY entries in regedit that were suggested. This allowed it to be removed. Installed the newest version it states mce buddy service is unavailable. Software was working prior to the new install. Tried restarting the service - doesn’t work… HELP Tried uninstalling repairing reinstalling etc…

Paid member


(RBoy) #2

Have you tried starting it from the control panel Services option?
You may want to follow the “Clean Install” procedure in case something is amiss.
You can also open the windows logs and see if there is an error from the MCEBuddy service posted.


(Rob) #3

Yes started it from services.

I’ve just uninstalled it seemingly successfully and installed 2.4 release 6. It does exactly the same thing unfortunately - service is unavailable. However I have noticed that it doesn’t install all of the associated programs as it did during the original installation. Unfortunately I don’t have system restore on this machine - I think it has something to do to with the keys I removed in regedit…


(Rob) #4

Error 17-Jul-2017 5:56 PM
Unable to complete initialization of MCEBuddy Engine Core.
Error: System.InvalidOperationException: This access control list is not in canonical form and therefore cannot be modified.
at System.Security.AccessControl.CommonAcl.ThrowIfNotCanonical()
at System.Security.AccessControl.CommonAcl.AddQualifiedAce(SecurityIdentifier sid, AceQualifier qualifier, Int32 accessMask, AceFlags flags, ObjectAceFlags objectFlags, Guid objectType, Guid inheritedObjectType)
at System.Security.AccessControl.DiscretionaryAcl.AddAccess(AccessControlType accessType, SecurityIdentifier sid, Int32 accessMask, InheritanceFlags inheritanceFlags, PropagationFlags propagationFlags)
at System.Security.AccessControl.CommonObjectSecurity.ModifyAccess(AccessControlModification modification, AccessRule rule, Boolean& modified)
at System.Security.AccessControl.CommonObjectSecurity.AddAccessRule(AccessRule rule)
at MCEBuddy.Engine.Core.CreateExposedDirectory(String dirPath)
at MCEBuddy.Engine.Core…ctor()


(Rob) #5

These are the keys I deleted previously

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Assemblies\ (delete keys)
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\ (delete key)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Folders(delete entries)


(Rob) #6

Just did this and intalled the latest - didn’t work still…

Uninstall MCEBuddy from the Start Menu or the Uninstall Programs Shortcut (Control Panel)
Delete the MCEBuddy Service: Find cmd.exe or command.exe in the Start Menu -> Accessories. RIGHT CLICK on it and select “Run as Administrator”.
In the command prompt type sc stop MCEBuddy2x and press Enter. This should stop the MCEBuddy service.
Now type sc delete MCEBuddy2x and press Enter. This should delete the MCEBuddy service. Do not worry if it gives an error saying service does not exist. NOTE: If you do not run as an administrator then the service deletion will fail and MCEBuddy will not install.
Delete the installation directory (usually C:\Program Files\MCEBuddy2x) - you will have to check where MCEBuddy was installed
Delete the backup configuration files stored by MCEBuddy. Open the folder %HOMEPATH% (this is a windows variable, just type that into your Run Prompt or Windows Explorer). Delete the following 3 files if found, mcebuddy.conf, profiles.conf and history
Reboot the computer


(Rob) #7

Is it too late to get a refund?


(Rob) #8

Ok - it’s kind of working - it will convert a file if it is on my local machine however it won’t do the same on my synology nas. It won’t even transfer a file across from local to network?


(RBoy) #9

That’s your issue, a corrupted file system. Did you go through the installation issues page and see the problem on the canonical issues?


(RBoy) #10

Did you enter the network credentials. Everything is documented in the Wiki’s, do spend some time with them.


(Rob) #11

I have read and reread the instructions I’ve tried leaving it blank with great as user, and using admin and my synology password. Doesn’t work at all… I


(Rob) #12

Guest - as user


(RBoy) #13

Go through your mcebuddy.log file and see that error code that will tell you issue. It’s a configuration issue, either on the NAS or how it’s entered in MCEBuddy. Some NAS require you to enter a Domain name also in addition to the username or domain\username