Service running, MCEBuddy won't load


(Cody Brown) #1

I recently upgraded to 2.4.8, and am running Windows 10. Since installing this new version, I get a “Microsoft .NET Framework” error when trying to launch the user interface. “Unhandled exception has occurred” etc. “Access to the path 'Global\MCEBuddy.GUI.exe” is denied. If I continue, the interface loads, but is not working, it just displays XXX instead of the current version. Can’t run jobs or anything. I keep seeing references to “canonical form” and that I need to reinstall or do a clean install. I don’t have that error in Event Viewer, but I’ve tried both a reinstall and a clean install and still have the same issue.

Services.msc shows that the service is running as does running “net start” in command prompt.

If I manually stop and restart the service, however, it comes up just fine. Consequently, I have to do this after every restart. Any ideas?

UPDATE: If I right click the application shortcut and “Run as administrator…” I get a different error, and it says “Cannot start duplicate instance” “MCEBuddy Status application is already running”.


(Goose) #2

One of 2 things:

  1. Either your .NET configuration is corrupted w.r.t. to MCEBuddy
  2. Your MCEBuddy installation is corrupted

2nd one is easy to fix, do a clean install (see the Common Issues topics for how to do a clean install)
For the first one you would need to run a .NET repair / reinstall utility


(Cody Brown) #3

I’ve tried the clean install, and the manual uninstall to no avail.

I just tried Microsoft’s .net repair tool, and it didn’t seem to do anything either.

Because .NET is incorporated into Windows 10, it pretty much makes it impossible to uninstall and download a new version. Parts of .NET appear to be available for deactivation through Windows Features. Disabling and re-enabling all .NET windows 10 features did nothing.


(Goose) #4

It could be your antivirus or some software blocking access to the EXE file, try to disable your AV/Malware/Security/Defender etc.

Essentially when windows tries to start it automatically something is preventing it (a corruption may be unlikely given that you can start it manually by clicking on it and you’ve performed a clean install).


(Cody Brown) #5

Unfortunately, I think this is a case of self-inflicted stupidity. Somewhere along the line, I had a scheduled task to open the MCEBuddy interface upon system start. I think it all got a little confused and was running the GUI process without it being opened. I didn’t even remember that scheduled task was there until I was looking to create a new one to automatically restart the service upon system start.

I think I’m all square now.