When converting .ts file to .mp4 the video keeps going blank

I purchased version 2.5.3 and it has been running fine for a long time on my Plex server. I’ve upgraded the computer and download version 2.5.7. The tuner is HDHomeRun and my intentions is to make a smaller file with h.264 and removing the commercials (Convert to MP4). It kind of works, when played on Plex the video keeps dropping out with a blank screen. I tried viewing the same file with VLC and got the same results. I tried to set my new system up like the old but apparently, I’ve missed something. The audio works fine even when the screen is blank. Can you help?

Does the problem go away when you go back to 2.5.3?

Yes, it’s on a different computer. The old computer has no problems other than being slow.

Will need the logs from both versions to see what’s going on. Preferably on the same file

2.5.3 - NBC Nightly News With Lester Holt (2015) - S2022E153 - NBC Nightly News With Lester Holt.ts-Convert to MP4-2022-06-03T19-04-42.log (1.5 MB)
2.5.7 - NBC Nightly News With Lester Holt (2015) - S2022E153 - NBC Nightly News With Lester Holt.ts-Convert to MP4-2022-06-04T15-51-55.log (2.3 MB)

These are the log files using the same .ts file. 2.5.3 plays fine and 2.5.7 has the video dropouts. Thanks for your help.

Thanks for the logs. You’re using hardware encoding and you have different graphics cards and different graphics drivers on each system. When using hardware encoding the driver is responsible for the video encoding (not MCEBuddy, it hands the video encoding off the drivers). There in lies your issue, the fault graphics driver is creating the video issue.

There are two possible solutions

  1. Turn off hardware encoding in the Conversion Task → Expert Settings page
  2. Change your graphics driver to a more stable one (latest is not always best). See this topic for a list of recommended drivers (or use the driver from the system that’s working). GPU/Hardware Encoding/Acceleration FAQs

2.5.7 10sec clip
I don’t know if this will help but it shows the problem.

You nailed it. Turning off hardware encoding fixed the problem. Looking at the stable windows 10 graphics driver in your link it doesn’t support the Alder Lake class. What drivers can be used for a 12700k I7 chip? Thanks.

Try a few and do feel free to share back with the community what version works best for your hardware.

I would also recommend switching to H.265 (x265) codecs. Even smaller files and that’s where content is headed, especially HD and 4K content. Plex does fine, and most players can do the x265 natively, so Plex doesn’t need to transcode either.

I’ve switched to all x265 encoding, and converted everything else separately with handbrake. Haven’t looked back.

Thank you Mike. It looks like hardware encoding works when using h.265.

1 Like

Mike, are you able to get subtitles with x.265? I took your suggestion but I can’t get subtitles to work.

Re: subtitles.
That prob depends on if they’re in the media or if you’re adding them via a SRT file. And if you want them burned in or not.

I don’t rely on subtitles, so I’m not sure if they’re already in my recordings from Silicon Dust’s HD Homerun Quattro tuners and the SD DVR.

I do know that I’m using the MKV (Markov) container file format, which supports subtitles. I’m not sure if the MP4 container format supports subtitles, so that may be part of your challenge.

Then there’s the playback problem for your media player to support whatever subtitle method you’re using, embedded in the container or as a separate file (and how the player locates and loads that SRT file).

I use Plex for viewing via my Tivo with its Plex app. I view media directly on the PC with VLC, which looks for SRT files automatically as well as embedded subtitles. Viewing through the Tivo with the Plex app almost guarantees it doesn’t support separate SRT files. But Plex could surprise me here if it transcoded the stream for the Tivo automagically.

I hope you find a workflow that works for you.