Sort Order in History of Conversions

Request Type:

MCEBuddy Version and Type (32bit or 64bit):
2.4.9 Beta 64bit

Operating System and Type (32bit or 64bit):
Windows 10 64bit

Summary of the problem or suggestion:
When I click the Converted On column header, MCEBuddy does not sort the column correctly. March dates are after February.

This is not a trivial problem as this is the easiest way to keep track of the most current conversions.

This is after a click of Converted On:

I cannot replicate the issue, it’s showing up sorted correctly here. Can you attach your history file so we can replicate the problem

Also what’s your system date/time format? (dd/mmy/yyyy or mm/dd/yyyy)?

Thanks for looking at this. I have posted my history file below.

Here are my formats … I use dd-mon-yy which might be less conventional. (10.2 KB)

I’m unable to replicate the issue not matter what I try, it’s sorting it perfectly every time.

Can you try it on a different machine?

Now it’s getting stranger.
I installed on another machine, moved my history file, and I have reproduced the problem.

Some things to note:

I have installed the 2.4.9 Beta from mid-February, not 2.4.8.
Both machines are Windows 10 64-bit.
This problem exists for me regardless of my short or long date settings.


update: I re-installed with 2.4.8 and everything is fine … no issues.


.NET quirk…sigh.

So … legitimate bug that can be fixed?

It’s a .NET issue not MCEBuddy

Apologies … I don’t understand. If this works fine with 2.4.8 but not 2.4.9, where does .net come into play and why can’t it be addressed to work like 2.4.8 does?

2 reasons:

  1. This wasn’t touched in 2.4.9, so the code is the same
  2. You mentioned it’s working on a different system

On a single Windows 10 system: I installed 2.4.9 for the first time and got the incorrect behavior.
I then uninstalled 2.4.9 and installed 2.4.8 on the same machine and it works correctly.

I’m sorry to be a pest here, but since the same history file sorts with 2.4.8 and does not with 2.4.9 … that this is an MCEbuddy problem not an external problem.

Using the latest x64 build of 2.4.9 and your above history file, I’ve tried this on every machine I could lay my hands on from windows 7 to Windows 10 and I can’t find an issue. So unless there are additional reports or we can find a replicate the issue I can only assume it’s something with your setup.

I also double checked and this code hasn’t been touched since 2.4.8 so it’s identical between 2.4.8 and 2.4.9

I’ve made a change to way the window sorts the “text”, forcing windows to do a unicode comparison instead of the default - shot in the dark, it’s possible the “default” may be different for different installations which could be why some of your computers handle sorting differently from others.

Try today’s build and see if it helps.

Thanks. I tried this with the 4/21 build and the everything seems right with the sorting of the dates.

Please note that I lost some of my original history in a hard-drive crash so I’m no longer able to test with the original history values. However…it seems that all of my current history is sorting in the correct order.

1 Like