QSV not being recognized/starting


(Brian) #1

I purchased MCE Buddy (tried out free version to see how it works) for the hardware acceleration but I am having a hard time to get working. I have Quick Sync working on my computer (installed a program called Action! and it shows QSV is active).

I have i5-3570k with Powercolor amd Radeon 7870 Myst edittion.
I have Intel HD Graphics 4000.
Am using 2.4 Beta 8 (02 Nov 2017) MCEBuddy

First try was with existing drivers:
INFORMATION> 2017-11-12T23:11:21 MCEBuddy.AppWrapper.Handbrake --> QuickSync encoding supported available -> False

Second try was with the 64bit driver found in #2 of MCEBuddy
INFORMATION> 2017-11-13T00:38:46 MCEBuddy.AppWrapper.Handbrake --> QuickSync encoding supported available -> False

UPDATE - I went to check on the driver info - it seemed to me that the driver did not change after the restart showing 10.18.10.4358 even after the install and restart of the included file.

Any help would be appreciated


(Brian) #2

I was able to get hardware encoding working completely with a program called mediacoder however i link the idea of removing the commercials and the ease of use this program. The trouble is with the QSV h/w/encoding working through mediacoder i am to encode at 2.1x speed on my system, meaning it can complete the encode of an hour show in 28 mins which is quicker than possible with handbrake which is running at less than 1x so even though commercials are left in it is much faster to use mediacoder. I really want this program to work since I paid $30 under the advertisement that QSV h/w encoding was working and included which for me it is not.

Any help getting this to actually work as advertised would be appreciated.


(RBoy) #3

Attach your conversion log and let’s see what’s going on.


(Brian) #4

Here is the log file. Thanks so much for helping out, really want this to work out (wife not happy nor 1 with the constant 15 sec delay to load ota dvr recordings at start of playing a file or after ff/rew action so this is my chance to save my “cord cutting” experiment).

SECOND NCIS New Orleans (2014) - S04E05 - Viral.ts-Convert to MP4-2017-11-13T00-36-36.4167720-06-00.log (566.3 KB)


(RBoy) #5

So the logs are showing the handbrake is unable to detect your Intel chipset

2017-11-13T00:38:42 MCEBuddy.AppWrapper.Handbrake --> [00:38:42] Intel Quick Sync Video support: no

You obviously have a quicksync chipset is what you’re saying and you’ve confirmed by alternative means.

Coupe of things come to mind:

  1. Drivers, are you able to use any of the recommended drivers?

  2. Do you have another video card? If so change your BIOS settings to make your Intel card as your primary video card (handbrake only sees the first video card)


(Brian) #6

I tried the included driver from the faq post but it didn’t work, I went and got the newest driver from intel (Download Intel® Graphics Driver for Windows* [15.33]) and that didn;t work either. Today, I will try to get some images of the BIOS from my asrock z77 extreme4 so you can see my settings there.

Here is a screenshot showing the cheat method to ensure that QSV is indeed on and working:


(Brian) #7

I am assuming you want me to set my primary graphics adapter to onboard yes? If I do that will I still be able to use the PCI? I have dual monitor running off the PCI and actually nothing attached to the onboard since until QSV it was not worth using. If I switch to onboard would have to try to find a monitor a plug into it? (currently monitors have 2 hdmi ports only)


(RBoy) #8

Don’t see any reason why it shouldn’t work. And you may need to connect a monitor to it, depends on how your drivers bring it up. Try it out.


(Brian) #9

Tried it out with a monitor hooked up and it seems to be working. After tonight’s recording Ill try without a monitor hooked up. Thanks for the help.

Quick couple of question: came upon your site from a youtuber named Lon Seidman from Lon.tv and he mentioned something about a donate version of comskip. I read here (How to Speed Up Comskip Commercial Detection and Install the Donator Version) about that version and was wondering if I need that to get that also (my files are all mpeg2 from OTA antenna)?

I noticed that MCEBuddy copies the file to working directory, would it improve speeds if i made the working directory on the same disk as the files? (the files are stored on a NAS and was thinking if the working directory was on same drive the copy function before process would be faster as well as the copy function of the finished product back)


(RBoy) #10

Not really, it’ll help with mpeg4 and WTV files

I don’t think so but you can try it. Usually the best performance will come from local drives and SSD drives or RAM drives for Temp folder, it’s not just copying but editing, cutting, joining etc which is very disk intensive and using a NAS is basically slowing it down.


(Brian) #11

RBoy you are great help and I appreciate it since it is making my “cord cutting” experiment be much better, sorry for so many questions.

Here is my complete setup for now while i figure this out.
Hdhomerun quantro tuner
Roku ultras at each tv
Plex Media Server is run on a Dell S530 Win10 pc with a Q6600 (no qsv) and 3 gb ram
Storage is on NAS which is Synology Diskstation D216j
My gaming pc is a personal build I5-3570k with a Radeon HD 7870 Myst OC and 16gb ram

I run Plex on the Dell because I play Warcraft on the gaming pc so can’t have my gaming cpu get bogged down with the plex server stuff. I use the NAS to store the shows that plex creates because then I had the chance to play them outside of plex and the transcoding delay caused (on my gaming pc plex would still cause delays of 10 secs even though the pc can natively play mpeg2).

Plan on using mcebuddy (what a great program btw) on my gaming pc from 2am to 630am every day to transcode the previous days shows into h264 so that I can load the shows without the 15-20 sec delay that Plex causes on the mpeg2 due to transocidng and have usable ff/rew from plex (again 15-20 sec delay after using rew/ff due to slow pc and transcoding I assume). Some times the wife is unwilling to wait until next day for a show so the mpeg2 version needs to accessible for her to play even if takes a long time to start up and because of the transcoding delay rew/ff are not really usable (she gets impatient for The Big Bang Theory)…

I am trying to make my existing gear work for now and after really learning if we can live cord cut then I might be willing to build a new gaming rig and make the existing gaming pc be the plex server pc (if i build something new I want it for playing game more then ota dvr lol).

I spent days buying and researching the possibliity of a different streaming box that could play the mpeg2 files natively thus requiring no transcoding but for whatever reason there just isn’t anything that I could find that fit the bill (either too costly apple tv, didn’t have amazon prime video mibox, couldn’t deinterlace amazon fire tv, no mpeg2 decoder any more new amazon fire tv, etc etc etc). So i’m trying to make the best out of the ota antenna with plex dvr with what i currently own.

Whatever advice you have for more efficient setup or workflow would be greatly appreciated.


(Goose) #12

You may want to start a new thread and ask the community. Some serious folks around here like @ThomasH5555 who can advise


(Zippy The Chicken) #13

To activate the QSV on the CPU you need to install the HD Video Drivers from Intel’s Website
This might help you… windows update drivers won’t cut it for the QSV option you need the Intel Drivers
Will they work along side your video cards drivers? idk

good luck