Help Configuring MCEBuddy

Hi,
First, thanks for this tool, I’ve been using it for a long time now and it solved my problems by automating all the stuff I had to do with TV recordings.
But, I think even though it works, I think I’ve some incorrect configuration as I believe the processing should be a lot faster, plus sometimes there are a few issues with the resulting conversion I’d like to sort out.

First, all I process through MCEBuddy are TV recordings (I’m in Australia), where I believe all of them are at 25fps, and most will be x265, ac3 audio, and either 1080i or 576i

The reasons I use MCEBuddy are:

  1. Want to extract cc/subs from the recorded stream (most of the time they are there).
  2. Removing commercials is great.
  3. Convert them to MP4 because I use PLEX and plex doesn’t play .ts with .srt

Issues I face:

  1. conversion taking too long. I assume this has to do with the profile I have? but I don’t know what to change. I assume given the source and target are x264 it should be a fast conversion but it takes longer as if it was “converting” the video
  2. comskp works almost ok. It cuts ~1 second before the commercials, and can see some commercials before starting again. I’ve tried the padding, cutting before/after but then the subs go all out of sync. Not just by x seconds, but compounding after every break.
  3. I’ve an nVidia card, not sure if it’s taking advantage of that.
  4. profile is set to use handbrake, but it fails constantly. I don’t mind/care what tool it uses to convert, as long as I get the result. I think ffmpeg can do a stream copy of the video and maybe convert the audio to aac, this should be faster, but don’t know how to set this up

Edit:
5. One more thing I face but prob has to do more with plex. Sometimes the show I record airs 2-3 episodes back to back. NextPVR records 3 separate episodes. Seems there’s no metadata (season/episode) in the recording, so I resorted to a long naming convention that includes showname , date and time. But plex recognises this as a single ep and 2-3 copies of the same rather than separate episodes. Any help in a better way of sorting this? post processing?

If someone can help me with this? I have uploaded the original file, converted file, profile and debug log if this will help with the right configuration
thanks

So you seem to have a case of bad drivers here, no matter what MCEBuddy tries your hardware doesn’t seem to be cooperating. Here’s what I see from your logs, MCEBuddy detects both Intel QSV and NVidia NvEnc hardware encoders:

“gpus”: [
{
“hardwareBrand”: “Intel”,
“codecType”: “Encoder”,
“hardwareCodecPresent”: true,
“h265Codec”: false,
“h264Codec”: true
},
{
“hardwareBrand”: “NVidia”,
“codecType”: “Encoder”,
“hardwareCodecPresent”: true,
“h265Codec”: false,
“h264Codec”: true
}
]

So it first tries to use your Intel QuickSync hardware encoder but that fails because your driver doesn’t seem to support hardware decoding:

2020-01-30T10:08:14 MCEBuddy.AppWrapper.Handbrake --> [10:08:14] thread b started (“Quick Sync Video encoder (Intel Media SDK)”)
2020-01-30T10:08:14 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 0.00 %
–> Process exited with code 255

Then it tries again without hardware decoding, you driver gets further but then it fails again:

2020-01-30T10:08:16 MCEBuddy.Transcode.ConvertWithHandbrake --> Disabling qsv decoder
2020-01-30T10:10:57 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 25.11 % (61.51 fps, avg 63.42 fps, ETA 00h07m47s)Error code -17, hb_qsv_wait_on_sync 605
2020-01-30T10:10:57 MCEBuddy.AppWrapper.Handbrake --> ERROR: encqsv: MFXVideoENCODE_EncodeFrameAsync failed (-17)

Then it tries to use your NVidia card, but then your Nvidia driver just doesn’t seems to want to cooperate:

2020-01-30T10:11:02 MCEBuddy.AppWrapper.Handbrake --> [h264_nvenc @ 000000000bcc7880] No NVENC capable devices found

Finally it gives up on your handbrake and hardware and decides to try it all again using ffmpeg and your hardware encoder which seems to work and finally does the job.

This is why it’s taking so long. You need to get better drivers, see the list of stable drivers.
For your Nvidia and handbrake, check your primary video card in the BIOS settings and make sure it’s set to your Nvidia card, also make sure that your monitor is connected to the Nvidia card (see the fake monitor tip) to that it’s visible to Handbrake.

Also try using one of the stock profiles to begin with rather than a custom profile. You may also want to update to latest 2.5.3 beta version as we have eeked out some better performance from handbrake and hardware encoding.

thanks,
will try all this but,
am I better off doing the ffmpeg? as I said, I don’t care which tool is used for conversion.

Sure. If ffmpeg is more stable on your system just switch the profile order from handbrake first to ffmpeg first.