PreMeta Source file has been renamed or deleted by custom command

I use SageTV open source. I have MCEBuddy set to monitor the recording directory and process with the XML file and the move to a fold I have setup for the processed files. Every so often (not every time) MCEBuddy gives me this message, however the show is an hour long and I start getting this message 5 min in, and then again every few minutes for hours. I am not sure why I get this from time to time. I have 2 identical machine, ever clone drives so the same software and sometimes I will get this on one machine and not the others. The other problem I have is that on one of these machine I end up with left over Properties Files in the processed directory where on the other one they seem to be cleaned up correctly. Any help or things I could check would be greatly appreciated.

It basically means that MCEBuddy can’t find the file and this could be a for few reasons:

  1. If the source file is on a network drive/NAS your network connection had a temporary disconnection or was unreachable (you have a network issue here)
  2. An antivirus or some program locked the file making it unaccessible for MCEBuddy

this unfortunately wasn’t very helpful. I mentioned that it was 5 minutes into a one hour show, so of course something has the file locked, its called SageTV. why is MCE Buddy trying to convert certain programs before the program is done recording? Not always, but sometimes. And it is on the local computer and I only have windows defender on the system.

Then it’s an issue with SageTV as to why it isn’t locking the file from the beginning of show. MCEBuddy tests if a file is locked before it starts converting so it looks like SageTV isn’t locking the file at the beginning and then decides to lock the file 5 minutes into the recording.

But since you’re saying that it’s only happening in one machine and not the other I don’t think it’s SageTV it’s your setup that has an issue somewhere. Hence my original post still stands as the top 2 reason why a file would be inaccessible in the middle of a recording. Are you using a network share?

If you disagree and still think it’s SageTV causing the lock on the file you can instruct MCEBuddy to delay monitoring the file in the expert settings page of the monitor location. Set the minimum age to 15 minutes, now MCEBuddy will look at the timestamp on file since the last write/modification and wait for 15 minutes since the last write before it starts the conversion. This helps with software that don’t lock the file while recording.

1 Like

no it happens on both machines sometimes on the exact same show, sometimes only one or the other which is why I don’t think it is SageTV, the setups are identical. I guess it could be but considering I just mirrored the drive from one machine to the other I feel that is much less likely. But I will change the time before converting on one and see how that might differ from the other machine net time this happens. Thanks

It sounds like you’re trying to process the same file on a network share from two different machines. If so That may be your issue. It isn’t MCEBuddy that’s locking but the underlying software is uses during the conversion process that could be locking the file making it inaccessible to the other machine at a random time in the conversion process. You should definitely put a big delay on one machine in that case say about 1-2 hours (however long it takes one machine to complete the conversion).

no it’s not on a network drive, they both have 2 partitions on the local hard drive C and D I record to D on each locally

So you have 2 instances of the mcebuddy engine running on the same machine?

no I have 2 machines, each identical hardware and software, but I have a C partition and a D partition on each one, the recording directing and conversion directory are both on D

If SageTV isn’t locking the file then putting a delay in the Monitor location will solve your issue.

If it’s some other app locking the file you will need to track it down. Likely and antivirus software. Disable it and then try it