Post Custom Command does not run anymore

In the recent week or two issues have come up with the Post Custom Command. A batch file described in the Post Custom Command argument should run after conversion but it doesn’t do what it has done until recently. I haven’t changed anything in the profile or MCEBuddy settings for that matter, and the batch file that is supposed to run works fine when run manually. Has something changed or do I have something wrong here:

PostCustomCommandPath=C:\Users\jarre\Documents\MCEBuddy Post Custom Command.bat

Path is correct, and the batch file itself does not need any parameters passed to it.


Looking at log file it seems I’m getting “access is denied” all of a sudden. How can this be fixed?

2018-06-11T19:47:36 MCEBuddy.AppWrapper.Base --> Launching process c:\users\jarre\documents\mcebuddy post custom command.bat
2018-06-11T19:47:36 MCEBuddy.AppWrapper.Base --> Process arguments
2018-06-11T19:47:36 MCEBuddy.AppWrapper.Base --> UI Session Admin Process : False
2018-06-11T19:47:36 MCEBuddy.AppWrapper.Base --> Setting process priority to Normal
2018-06-11T19:47:36 MCEBuddy.AppWrapper.Base --> c:\users\jarre\documents>forfiles /P “G:\DVB Recordings in MP4” /M *.mp4 /C “cmd /c copy @file “H:\My Drive\MP4 Backup””
2018-06-11T19:47:36 MCEBuddy.AppWrapper.Base --> Access is denied.
2018-06-11T19:47:36 MCEBuddy.AppWrapper.Base --> 0 file(s) copied.

is drive H a mapped drive? or a removable?

Drive H has been created by Google Drive File Stream (previously known as Google Drive), basically a virtual drive to access Google Drive directly. Hmm maybe if I’ll try to re-install Google Drive File Stream, let’s see if it fixes the problem.

You probably should link directly to where the files are located locally instead of the Google Drive File Stream virtual drive H:. Go into settings and see where the local Google Drive folder is. That might work. I don’t think the virtual drive will work.

Re-installation changed nothing. By default, Google Drive File Stream seems to assign itself an independent drive letter and I can’t find where the actual mount point is.

This configuration worked for months, and when I manually run the batch file (that I would like to run as a post command) it works fine: file gets copied to Google Drive folder without problems. It’s only recently that running the batch file as a MCEBuddy Post Command that it has started to not work as expected.

I can always have another program monitor the location of finished conversion jobs and have it copy files over to Google Drive but it would be a step easier to have the finished file automatically copied over to Google Drive the instant it is ready.

CustomCommands are run in the context of service. If your google drive mapped to a user account then it’s not available to a service (like any other mapped drive).

See the topic for information on mapped drives:

The other way would be to set:


This tells MCEBuddy to run the custom command from the currently logged on users UI session, in which case it will have access to the mapped drives for the logged on user