MCEBuddy ignoring excluded folders

I am using Plex with MCEBuddy 2.4.7 and while plex records something it puts it in a .grab folder in the same place as all the rest of my tv show (I.E. My complete recording tv shows) I have excluded .grab and all it’s subdirectories but MCEBuddy still trys to work on the file. is this because it’s a . file? help would be greatly appreciated!mcebuddy.log (2.2 MB)

Attach your MCEBuddy.log file, it’s probably a configuration error. Any directory which is excluded will not be scanned.

There you go! I uploaded the mcebuddy.log file!mcebuddy.log (2.2 MB)

Looked at your logs and it’s working, fine, its’ exclude the files in the .grab directory

WARNING> 2017-07-26T18:39:45 MCEBuddy.Engine.QueueManager --> Monitor task plex : File \GIDIERE\Media\Series.grab\c0420b9fad2ce8d7b0e8a418ddbc70864b998fb5\Marvel’s Agents of S.H.I.E.L.D. (2013) - S01E22 - Beginning of the End.ts is in an excluded directory (@Recycle), skipping monitoring

I also verified independently that it’s working as expected here. (the debug message is slightly misleading as it doesn’t list the excluded directory which we’ll fix in the next release, but it’s excluding the files).

I did see in the log one place where you specified the excluded directory as .grab instead of .grab* and in that case it excluded only the files in .grab directory but not the sub directories. However when you changed it to .grab* it also excluded all subdirectories

So it’s behaving as expected. Can you provide an examples file in the log where it’s processing a file it should not be processing?

I am no expert with MCEBuddy Logs but I think I found a incident where this happend:
WARNING> 2017-07-26T18:37:28 MCEBuddy.Engine.QueueManager --> Monitor task plex : File \GIDIERE\Media\Series.grab\c0420b9fad2ce8d7b0e8a418ddbc70864b998fb5\Marvel’s Agents of S.H.I.E.L.D. (2013) - S01E22 - Beginning of the End.ts is in an excluded directory (@Recycle), skipping monitoring
2017-07-26T18:37:28 MCEBuddy.Engine.ConversionJob --> Starting Conversion Thread
i have nver looked in the log file so i may be wrong!

See my previous post

oh ok then it’s fixed! :smile: By the way i love MCEBuddy thanks for all the work you guys put into this!

1 Like