MCEBuddy 2.4 Beta (May 25 and previous beta build) fail to open in A's Video Converter and others

So this problem remained through the 2.4.9 beta builds and continues with .10 as well.
The ‘work around’ I found was to change the conversion task to .TS Unprocessed.

That was fine, but 2.4.9 builds using MKV Unprocessed for the final output to my TV Collection folder(s) containing HEVC/.265 video would not seek, scan or resume playback in Plex and weren’t able to OPEN using VLC (on Windows) – Microsoft Movies & TV player would play, but also shared playback the issues with Plex - no seeking, ff, etc.

So I ‘upgraded’ to the latest .10 beta and A’s still can not read/convert MKV created with MCEBuddy, it can work with the same files in TS format (MCEBuddy MKV (any version) re-muxed with MKVToolNix are ok).
The mkv files created by MCEBuddy play, scan, resume perfectly in Plex and play in VLC too!
However, the .10 version of Plex WILL NOT correctly match my TV files to TheTVdb, IMDB, etc. For files with “title sXXeXX episode title” they will be placed into the correct folder, but files such as “title sXXeXX” NEVER are looked up and updated with episode title or placed in the proper folder. Instead they placed in their own separate folders.
title sXXeX1\Season 0\s00e00 -.mkv
title sXXeX2\Season 0\s00e00 -.mkv
title sXXeX3\Season 0\s00e00 -.mkv

It’s more than a little maddening and makes it impossible to reprocess all my HEVC seasons already stored by MCEBuddy.

Is there a change I can make to MCEBuddy 2.4.9 to have it generate playable x265 MKV videos?
I am getting tired of new issues with each update and would be happy to STOP the cycle and, once again, have a reliable system to organize my files.

Before upgrading from “MCEBuddy 2.4.9 64bit - 20180920” (later versions had the same or similar issues) I did backup the Program Files folder, so I do have access to the old log files and new log files.

I would also recommend using today’s 2.4.10 BETA build. We have a new version of ffmpeg. Possibly may have fixed your ffmpeg profile issues and also a few fixes related to metadata matching.

If you’re still facing an issue please attach your conversion log with the 2.4.10 BETA run so I can see what’s going on. Also if you can upload the original file to the MCEBuddy server which has an issue with the MKV Unprocessed profile to our server then I can replicate the issue and deep dive into it otherwise it’ll be harder to pin down what’s going on.

1 Like

Ok I’ll check for the new BETA build.
A Couple of Questions

  1. Does it matter that I am installing MCEBuddy via Remote Desktop Connection (admin account)?
  2. the new ffmpeg version doesn’t have support for AMD HW encode and decode does it?? :slight_smile: [Nevermind, I see in the notes it ‘only’ improves NVidia HW) boo! :wink:

Ok, todays BETA build (dated 2019-01-11) doesn’t work at all.
None of my Conversion Tasks are working.
This is my mcebuddy.logmcebuddy.log (85.9 KB)

ERROR> --> Unable to extract Season and Episode information using pattern match 1, System.IndexOutOfRangeException: Index was outside the bounds of the array.
at MCEBuddy.MetaData.VideoMetaData.ExtractSeriesEpisode(String text, String& preText, Int32& Season, Int32& Episode, String& postText)

followed by ~500 more lines of errors
Below are my Config Files
mcebuddy.conf (29.9 KB)
profiles.conf (98.2 KB)

UPDATE: After tinkering around a bit, I re-installed MCE Buddy and it now processes the videos, but the update to today’s build didn’t solve the problems I am having.

I just uploaded 4 files to my folder on the ftp server john_freiman
2 episodes and 2 log files.

Any help you can provide would be helpful – AND APPRECIATED

You can install MCEBuddy using a Remote Desktop (without a user logged in hardware accelerations may not work on Windows 7)

The new builds improves also supports AMD AMF hardware acceleration but you need to write a custom profile for it until MCEBuddy supports automatic detection of AMF capabilities. Feel free to try it out and post your feedback on the this topic.

Thanks for uploading the file, however your logs are empty, set the log settings to Debug in your System Settings page and upload them again. Also upload your profiles.conf and mcebuddy.conf files so we can replicate it and see what’s going on.

Ah! Thanks, I saw that the Log was checked on the General Settings and while I looked at the 2nd page of the Settings (System Settings) I didn’t initially see the Logging Level drop down! :persevere:
I’ll set that now and re-up the results with the same two files.
As for the AMF support, I think I’ll wait on changing that until after I get the metadata working again.

Old logs have been deleted on your ftp and the new ones with the Debug option have been uploaded – again, for the same mkv files previously uploaded.
Thanks again – I don’t know why I seem to be the only one with this issue – but I’m hoping it’s something stupid that’s easy to correct.

The other thing on the back of my mind is that this is a hiccup that incurred from using highly modified Profiles.conf and Config.conf files a couple of years ago to a (I think) clean and modern conf files today.

That said, I have done side-by-side comparisons of the old and new conf files and can’t see any differences other than my Conversion Tasks and my custom Renaming and Sorting parameters…

Thinking it was possible that I had “too many” Media /Title Corrections; I even created “clean” Tasks which have zero Media Information Corrections for hard to match titles - with the intention of making it easier for you to look over the logs. :confused:

Super helpful. Found and fixed the metadata reading issue (your filenames were missing a subtitle, e.g. The Flash - S02E01) which is now being handled properly. You can use today’s 2.4.10 BETA 10 and it should resolve your metadata issues.

As for your conversion profile, I see that you have a working profile which you mentioned above:

[MKV Unprocessed Old]
Description=Very fast but limited functionality. Use this profile if you want to copy the original audio and video tracks, remove the commercials and convert the file format to MKV (e.g. WTV to MKV) without any additional processing (deinterlacing, resizing, volume, cropping etc). The original video can be in any format, MPEG1, MPEG2 or MPEG4/H.264, it will be retained unaltered.
ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vcodec copy -map 0:v -sn
ffmpeg-audio=-acodec copy -map 0:a
ffmpeg-audioac3=-acodec copy -map 0:a

Try using this profile with today’s build and see how it goes.

1 Like

I also found an issue with your source file, the initial 5 seconds or so are corrupted which which why it can’t be read by explorer after conversion. Skip the 1st 10 seconds (use the Cut start option in under the Conversion Task expert settings) and the resulting file is ready perfectly and plays fine.

Thanks for discovering the faulty file – I uploaded 2 video files to the server, would you recall if the corruption was with Project Runway or the Future man video file(s)?
I am eagerly downloading todays beta update now and while I expect it to work, I will of course update this thread with my experience using it.

I don’t know what changed between early 2.4.9 beta builds to now for my files without ‘subtitles’ to get ignored or otherwise not matched properly, but I would like to own up to ‘my responsibility’ in this matter as I have tried many of the beta builds in 2.4.9 and I never took the time to share those problems with you and upload the needed data/files.

Thanks again, fingers crossed this sorts things out!!

Is this, MKV Unprocessed Old, you attached, the one which alters the muxing mkv files from ffmpeg to MKVToolNix?

I do remember trying this change a while back to see if A’s Video Conv could read my mkv files created by MCEB, but that still wouldn’t allow A’s to read/open the mkv files (thus I’m using .ts).

I’ve been using the default MKV Unprocessed profile for a while now. I did re-try using the setting this pas week, but it made no difference with regards to A’s and the mkv reading…

So for now, I copied the above ‘Old’ profile into the new build, but I don’t plan on using it.

OK, the update to Jan_14_2019 has been completed.
I processed 2 files, both had the subtitles looked up and added to the file name as per my custom naming setting!

But there is another issue now.
Poster artwork: Neither of the files had their poster artwork displaying in file explorer
Episode Metadata: The episode metadata was missing for one of the files (and did not have the poster.jpg attached – although the poster was found in the \programs\MCEBuddy2x\cache folder

is this related to the above problem or should I create a new thread?

At this point, I am hopeful I can remux all my HEVC episodes and seasons with MCEBuddy and be able to play them back via Plex and VLC! Phew!!!

Its the same one you posted above in your original post and said it work working for you.

This could be related to the file corruption first couple of seconds. Try it after cutting the first 10 seconds.

@RBoy found and fixed this issue, it’s a boundary condition for certain files which were affected by it that were created using the Unprocessed profile. It should be work with today’s 2.4.10 BETA build

1 Like

While I’m sure ffmpeg is good, I’m a little more comfortable with Handbrake as my encoder.
Does the Handbrake CLI supplied with MCEBuddy have the AMF support or is it just the ffmpeg that supports AMD hardware?

Just like you mentioned, the metadata, ie. description, air date etc is now back in the created mkv files. However, I am still not seeing the poster artwork…

It should be in there. It working here. Check your logs at the end to see if the posted was embedded. The it’s upto the OS to retrieve and display it. Windows isn’t good at extracting stuff from MKV files in general. MP4 is more standard.

See this page on how to enable MKV thumbnails in Windows using Haali Media Splitter settings:

MCEBuddy includes Haali Media Splitter in it’s installation extras directory.

Thanks for the article link.
I actually use Icaros (v3.1) I did not have the Haali splitter set for Explorer thumbnail extraction. I did make that change, restarted Explorer, no change. I restarted Windows, no change - ie. thumbnails still do not show.

As I mentioned before, the HEVC mkv episodes that were created using 2.4.9 would not play in VLC and had scanning (FF/Rew, resume) issues with Plex, so I am having to push all these episodes through MCEB 2.4.10 again - a little cumbersome, but well worth it and necessary.

I first noticed that the thumbnails were not showing, and then I noticed that the episode metadata (air date, description, etc) wasn’t being attached.

Now the metadata (2019-01-15) is being included, but I still can not see the thumbnails… It’s not the end of the world, but it is a little annoying.

Sometimes the first episode from the Series WILL show the thumbnail, but then all the following episodes processed at the same time will NOT show their thumbnails.

I’ll keep an eye on this, but right now my priority is finding the effected HEVC mkv episodes and push them through the new beta build(s).

Thanks again for all your assistance.