Incorrect series year matching

(Randy) #1

I’m wondering why when my source file is properly named, that the software ignores that and sometimes names things wrong? Such as two shows with the same name. If it can’t find it in its online search, can’t it default back to the original filename? I’ve attached the log file from one of the failed renamings.

Titans (2018) - S01E07.mkv-Shows NonComSkip-2019-02-05T13-14-59.1212540-06-00.log (878.9 KB)

(Goose) #2

I don’t see anything wrong here, it’s renamed and moved as expected:

INFORMATION> 2019-02-05T13:49:08 MCEBuddy.Engine.ConversionJob --> Moving converted file to destination
INFORMATION> 2019-02-05T13:49:08 MCEBuddy.Engine.ConversionJob --> Auto filename increment check enabled, checking if destination file \\nas2\PlexMedia\TV Shows\Titans (2000)\Season 1\Titans (2000) - s01e07 Torn Between Two Mothers.m4v exists and incrementing filename accordingly
INFORMATION> 2019-02-05T13:49:08 MCEBuddy.Engine.ConversionJob --> Moving converted file C:\Program Files\MCEBuddy2x\working0\Titans (2000) - s01e07 Torn Between Two Mothers.m4v to \\nas2\PlexMedia\TV Shows\Titans (2000)\Season 1\Titans (2000) - s01e07 Torn Between Two Mothers.m4v

BTW, your renaming pattern has in invalid character > at the end (it’s ignored by MCEBuddy but just FYI)
TV Shows\%showname% (%premiereyear%)\Season %season%\%showname% (%premiereyear%) - s%season%##e%episode%## %episodename%>

(Randy) #3

The problem is the original file name is Titans (2018) - s01e07 Asylum. It’s renaming it to a different show that came out in 2000.

[FEATURE] Compare series year with premiere year while matching metadata
(Goose) #4

I see what you mean, that’s a limitation of the way metadata is matched with the providers, it takes the first returned matching title. I’ve opened a feature request for this.

Meanwhile, the best way to correct is for shows that are remakes in a different year, get the TVDB ID or IMDB ID those shows in the enter them in the Media Information Management Correction box in the Conversion Task -> Expert Settings page. This way it’ll force MCEBuddy to use that specific ID for matching the metadata.

(Randy) #5

Ok I’ll give that a try. So does the source file name have any bearing on the outcome? Because I had them named correctly. At least from a plex perspective.

(Goose) #6

Yes, it does in some cases but it can be improved, this is an example where it doesn’t work fully so we’ll take this up internally.
I’ve opened a feature request so in future so it’ll minimize this extra step where possible.

(Randy) #7

Great. Thanks for the support.

(Goose) #8
(Randy) #9

Seems with this change that if you don’t provide the year already it just puts it as showname ().

(Goose) #10

Conversion log please