Removing Series (Year) After Conversion


#1

After just upgrading to 2.4.10 64bit I noticed that after converting a file, the series year was suddenly being removed from TV shows and all folders created by the program. This was creating new folders in my destination:

Sample Show (1999)
Sample Show

After downgrading back to 2.4.9 64bit, problem solved

Has this happened to anyone else?

Obviously from an organization standpoint this is maddening.


(RBoy) #2

Can you attach your conversions with 2.4.9 and 2.4.10 so we can compare what’s going on?


#3

Apparently, my uninstall of 2.4.10 erased all my old conversation logs. Is there anyway to retrieve them without re-installing and running new reconversions to create the problem?


(RBoy) #4

Not an issue, just attach your 2.4.9 conversion log for the file in question and we can run it on 2.4.10 and compare it to see what’s going on


#5

Jeopardy (1964) - S35E115 - Episode 115.ts-MP4 Normal Drobo-2019-02-15T19-33-15.9518289-05-00.log (746.6 KB)


(RBoy) #6

I think I see what’s happening. The file is named

Jeopardy (1964) - S35E115 - Episode 115

2.4.9 doesn’t recognize the (1964) and instead treats the entire “Jeopardy (1964)” as the Title.

2.4.10 we’ve added the ability to parse that tile more accurately and extra the premier year so 2.4.10 treats it as

Title: “Jeopardy”

Premier Year: “1964”

This is being done so that it can start matching the information on the internet to accurately which is beginning to be an issue since more shows are being rebooted these days.

Hence you see that your final file renaming has only Jeopardy in the title instead of Jeopardy (1964).

You can easily fix this by using the custom renaming option and include the %showname% (%premiereyear%) in the pattern to recreate the defective 2.4.9 behavior.


#7

Thanks for looking into this. I appreciate your help.

So this is my current custom renaming:

%ismovie%<MCEB-Movies%showname% (%airyear%),MCEB-TV%showname%\Season %season%##%showname% - S%season%##E%episode%## - %episodename%>

I’m still a little bit of a novice here. Would you mind telling me where would I insert your edit?

Thanks again!


(RBoy) #8

use %premiereyear% instead of %airyear%