Comskip randomly failed -- resolved

I was humming along fine with MCEBuddy and comskip removing commercials from half-hour shows. Then I added a one hour show and started to get failures of that new show. MCEBuddy would report “comskip failed” and cancel the conversion.

If I manually dragged the .ts file to comskip.exe it worked fine and completed without errors.

It turns out that MCEBuddy was killing the comskip process after it took too long to complete. I watched it manually and the commercial detection process APPEARED to freeze with 10 seconds remaining. During that time the comskip log grew and grew. MCEBuddy would eventually kill the process – I assume there is a fixed wait time – and report failure.

It turns out that the log on this particular show got HUGE. The default comskip setting for “verbose” is 5, and it was writing a TON of log data to the log file. Even though the work folder was on a SSD with a fast XEON processor, once the log file got really big it took a very long time to write each new line. I think that the comskip logging routine needs to be optimized.

Anyway, I changed verbose to 0 and it worked perfectly and really fast. MCEBuddy stopped killing it and completed the conversion.

I think MCEBuddy should either extend the timeout on the comskip process or make this a configuration option. But editing the comskip settings to set verbose=0 did the trick, even if it does mean no comskip details log.

1 Like

I get this issue too sometimes.
Where did you change the Comskip log level? I use Comskip Donator with MCEBuddy located in C:\comskipdonators.
I don’t have a customized INI file, so just the one.
I assume this would be the default ini file. Nothing to do with MceBuddy so If I turn it to zero, all good.

1 Like

Thanks for that information, we’ll edit the default log level for comskip in the next build.

Meanwhile you can adjust the hang detection timeout from the System Settings page:

This was a helpful post for me, but found a different solution for my specific case.

I had recently updated MCEBuddy for the first time in a LONG time. After the upgrade Comskip would hang every few files. I would have to stop conversions then restart and it would go through a few more files before hanging again.

I use the donator version and had neglected to update that as well. After updating comskip it seems to be running great again, no hangs.

1 Like