WTV->TS: false report on audio tracks missing after remuxing - then re-remuxing with 1 audio track only

Out of about 120 remuxing jobs WTV->TS one file can’t be completed correctly during a couple of tries.

The WTV comes with 3 audio tracks; the log shows that they are detected correctly by ffprobe BEFORE remuxing and also AFTER remuxing;

actually after remuxing a process directive says
--> Checking for 0 Channel Audio Tracks in...

after which an ffprobe instance is started and it lists all audio tracks in the TS file correctly; directly after that the following messages appear in the log:

WARNING> --> Found 0 channel audio track in file...
INFORMATION> ... Found 0 channel audio while remuxing, re-remuxing using a single audio track

Alvin und die Chipmunks 3- Chipbruch_Sky Comedy_2013_08_06_15_34_00.wtv-Remux to TS-2018-03-26T17-17-57.1159275 02-00.log (751.9 KB)

Finally I get a remuxed TS with only one audio track…

Any idea why MCEBuddy interprets a complete ffprobe of 3 audio tracks as “no audio track”?

If you look at the logs, while remuxing ffmpeg seems to encounter issues with the audio and video streams. So when it’s complete one of the audio tracks (deu) is not identified properly and shows up with any audio channels. So MCEBuddy skips it otherwise the conversion will fail downstream.

Basically the recording device created a non compliant stream.

–> [mpeg2video @ 000001fc5f1b1060] Invalid frame dimensions 0x0.
2018-03-26T17:18:09 MCEBuddy.AppWrapper.FFmpeg --> Last message repeated 1 times
2018-03-26T17:18:09 MCEBuddy.AppWrapper.FFmpeg --> [wtv @ 000001fc5f14ae60] Stream #5: not enough frames to estimate rate; consider increasing probesize
2018-03-26T17:18:09 MCEBuddy.AppWrapper.FFmpeg --> Guessed Channel Layout for Input Stream #0.2 : stereo

I noticed some of those messages and wasn’t quite sure of their meaning-
mainly because in other places I see that ffprobe seems to perfectly recognize the streams-

I’ll see if I can get a remux via VLC (plays all audio streams w/o issues)-

Thx a lot

You can try to check the box that says Skip remuxing on the conversion task -> expert settings page, see if that works better for you.