No Sound trying to use copy audio ffmpeg


#1

Hi,

I am trying to just copy audio in my conversions but I get no sound? can someone please look at my profile and log? Thank you

[My HEVC MKV]
Description=My HEVC in MKV My Custom HEVC Settings.
order=ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec libx265 -preset medium -crf 21 -map 0:v -sn
ffmpeg-audio=-acodec copy
ffmpeg-ext=.mkv
ffmpeg-audiodelay=skip

mcqueen.2018.limited.720p.b.mkv-My HEVC MKV-2018-10-26T12-21-03.9621750 01-00.log (1.8 MB)


#2

ok, I saw there was no stream selected & this works for AC3 (it just copies the stream) but how do I get the same for DTS? if the video has DTS there is no Audio in the processed file?

[My HEVC MKV]
Description=My HEVC in MKV My Custom HEVC Settings.
order=ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec libx265 -preset medium -crf 21 -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 320k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 320k -map 0:a
ffmpeg-audio=-acodec copy
ffmpeg-ext=.mkv
ffmpeg-audiodelay=skip
handbrake-general=–decomb --loose-anamorphic --verbose=2
handbrake-video= -e x265 --encoder-preset medium -q 21
handbrake-audio=-E ffac3 -R auto -B 320 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 320 -D 0 -a 1,2,3,4,5
handbrake-ext=.mkv
handbrake-audiodelay=skip
PreConversionCommercialRemover=false


(RBoy) #3

Did you notice that you’re repeating lines in your profile making it ambiguous?

ffmpeg-audio=-acodec ac3 -ab 320k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 320k -map 0:a
ffmpeg-audio=-acodec copy

What you should be doing in just replace -ac3 with -copy and remove the -ab, so it should look like:

ffmpeg-audio=-acodec copy -map 0:a
ffmpeg-audioac3=-acodec copy -map 0:a

Refer to the Profiles Basics topic for details on how profile commands work.


#4

Hi, Thanks so much for your reply and yes I can see it now! (sorry) I have amended my profile to the following but I get a conversion failure? also will these copy all streams? (FLAC, AC3, DTS etc)

Thanks Again!!

[My HEVC MKV]
Description=My HEVC in MKV My Custom HEVC Settings.
order=ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec libx265 -preset medium -crf 21 -map 0:v -sn
ffmpeg-audio=-acodec copy -map 0:a
ffmpeg-audioac3=-acodec copy -map 0:a
ffmpeg-ext=.mkv
ffmpeg-audiodelay=skip
handbrake-general=–decomb --loose-anamorphic --verbose=2
handbrake-video= -e x265 --encoder-preset medium -q 21
handbrake-audio=-E ffac3 -R auto -B 320 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 320 -D 0 -a 1,2,3,4,5
handbrake-ext=.mkv
handbrake-audiodelay=skip
PreConversionCommercialRemover=false

The Ant Bully (2006).mkv-My HEVC MKV-2018-10-26T14-51-09.1064012 01-00.log (1.5 MB)
mcqueen.2018.limited.720p.mkv-My HEVC MKV-2018-10-26T14-51-09.1343263 01-00.log (1.7 MB)


(RBoy) #5

Looks like ffmpeg is choking on your audio while trying to copy it, it’s a known open defect in ffmpeg.

Meanwhile add -max_muxing_queue_size 4000 to your ffmpeg-video line it should fix the issue.

ffmpeg-video=-ss 0 -max_muxing_queue_size 4000 -vf yadif=0:-1:1,hqdn3d -vcodec libx265 -preset medium -crf 21 -map 0:v -sn

If that still fails, try increasing 4000 to 99999

You can also remove the handbrake-xxx lines since you aren’t using handbrake

We’ll try to put in a detection for this error and automatic correction in the next build of mcebuddy

EDIT: Cross reference: Ffmpeg Bug - Too many packets buffered for output stream


(RBoy) #6

Can you upload a copy of the original recording to our server so we can analyze it and put patch for it.

See this topic for instructions on how to upload.


(RBoy) #7

This has been handled in today’s 2.4.9 BETA build. You can try it out.