Verison 2.5.3 and 2.5.4 ffmpeg error - cause slow remux and large files

Version 2.5.3 and 2.5.4 displays a audio track error and starts slow remuxing. Version 2.5.2 does not have this error. I have reverted back to using 2.5.2. I Looked in log files and shows fprobe error. Also this creates about a 3x size file as compared to the original file and slows conversion.
I have include the log files for version 2.5.4 and 2.5.2
ver 2_5_2 News 5 20090411 [20200807-2200].mpg-News %-2020-08-08T09-03-32.0686042-04-00.log (681.4 KB) ver 2_5_4 News 5 20090411 [20200807-2200].mpg-News %-2020-08-07T18-34-15.log (851.2 KB)

The issue appears be that your file is being blocked by another process which is preventing mcebuddy from accessing it and causing your issues.

WARNING> --> Error trying to read data to TS file. Error: System.IO.IOException: The process cannot access the file ‘C:\Users\Public\Recorded TV\HDHomeRun\News 5\News 5 20090411 [20200807-2200].mpg’ because it is being used by another process.

2020-08-07T18:34:15 MCEBuddy.AppWrapper.Base --> C:\Users\Public\Recorded TV\HDHomeRun\News 5\News 5 20090411 [20200807-2200].mpg: Permission denied

Also, when running 2.5.4 you’re running it headless (without a user login) where as with 2.5.2, you’re running with a user logged in:

2020-08-07T18:34:19 MCEBuddy.AppWrapper.Comskip --> Starting process as a UISession process with Admin privileges. This requires atleast 1 user to be logged into the system (remote desktop or locally)
WARNING> 2020-08-07T18:34:19 MCEBuddy.AppWrapper.Comskip --> Unable to create UI Session process with Admin Privileges from NonUI Session. Is any user logged on?

Thanks for responding back. I am quite perplexed at the user login as I have it to automatically log on with reboot. I installed 5.2 on same win session as 5.4. It also does same on my Win laptop. The file I used for the test was already recorded so it’s not on the fly. Don’t understand what other process would have it?

I am running the latest win updates since I have no choice. Seems strange that 5.2 ignores these issues and 5.4 doesn’t. Any suggestions as what to look at? Would like to run the latest rev. It’s a great product been using it every since I cut the cord.

Regards
Larry

goose,
I am running the donator venison of mcebuddy.

I tried this again and reviewed the log files with similar results. what I find is the ffprobe is being denied permission to the file.

2020-08-19T13:45:10 MCEBuddy.AppWrapper.Base --> \MY-MEDIA\Public\Recorded TV\HDHomeRun\The 100\The 100 S07E11 20200812 [20200813-0000].mpg: Permission denied.

This apparently locks the file which causes this error.

–> Error trying to read data to TS file. Error: System.IO.IOException: The process cannot access the file ‘\MY-MEDIA\Public\Recorded TV\HDHomeRun\The 100\The 100 S07E11 20200812 [20200813-0000].mpg’ because it is being used by another process.

I have tried recreating the error by running fprobe from its program directory with your cli commands and it runs normally with the expected output. So I don’t think its a privilege problem for fprobe.

I do notice that 5.2 does not fail user name guest login while on 5.4 failed user name guest.

manual Add User Name -> Guest
Manual Add Password ->
Archive Path Domain Name ->
Archive Path User Name -> Guest
Archive Path Password ->
Failed Path Domain Name ->
Failed Path User Name -> Guest
Failed Path Password ->

Any help is appreciated .

thanks

Larry

The 100 S07E11 20200812 [20200813-0000].mpg-DVR-Comm-2020-08-19T13-45-09.log (72.1 KB)

The 100 S07E11 20200812 [20200813-0000].mpg-DVR-Comm-2020-08-19T14-09-47.9638908-04-00.log (108 KB)

It’s not any program within MCEBuddy that’s locking the file, it’s something external. Probably something on your network machine or some AV. Try using a local file and if that works then you know it’s something tapping into your network drive.

don’t have it here so can’t test it but have seen reports that if using hdhomerun dvr service (since your folder named HDHomeRun) sometimes the lock not removed from file after recording done. if you setting mcebuddy to convert soon after recording ends maybe need to increase that?
I have had issues with mediaportal (using hdhomerun tuners) not releasing lock on file, using emby now and have not seen that. I start my conversions about 5 minutes after recording ends.

Goose,
all recorded shows are local on the same computer, Hdhomerun, mcebuddy, Kodi all reside on the same computer.

So I moved " The 100" show to downloads and manually added it to mcebuddy it gives the same result.

C:\Users\ldc76\Downloads\The 100 S07E11 20200812 [20200813-0000].mpg: Permission denied

5.2 does not give this problem but 5.3 and 5.4 does. So there is a difference between the revisions that causes and issue on this computer. Now mysteriously it is working on one of my Dell laptops and not on the other same model , with the same error. I have checked all the permissions they appear to be correct to me, I can run fprobe on the same file manually and it does not give the error. However when mcebuddy 5.4 or 5.3 launches it, it gives the error.

so I am stumped and glue less as how to proceed. I hate to be stuck at 5.3

Larry

David,
thanks for replying. I am testing the problem by manually added the show to mcebuddy. What is happening is when 5.3 or 5.4 launches fprobe it errors out with this below. It does not happen with 5.2. Now strangely I do have to Identical dell laptops that it works on one and not the other. Mcebuddy , hdhomerun, kodi is running on the same desktop server. What led me to this discovery is that when this errors out the program does a slow remux which takes for ever, it thinks it has an audio error.

I have run the same fprobe from mcebuddy\ffmpeg directory with same arguments with same show file locations and it runs and produces output. So I think permissions are correct. But it want run correctly with launched from 5.3 or 5.4.

2020-08-19T20:22:23 MCEBuddy.AppWrapper.Base --> Launching process C:\Program Files\MCEBuddy2x\ffmpeg\ffprobe.exe
2020-08-19T20:22:23 MCEBuddy.AppWrapper.Base --> Process arguments -hide_banner -probesize 100M -analyzeduration 300M -i “C:\Users\ldc76\Downloads\The 100 S07E11 20200812 [20200813-0000].mpg”
2020-08-19T20:22:23 MCEBuddy.AppWrapper.Base --> UI Session Admin Process : False
2020-08-19T20:22:23 MCEBuddy.AppWrapper.Base --> Setting process priority to Idle
2020-08-19T20:22:23 MCEBuddy.AppWrapper.Base --> Setting CPU affinity to -> 15
2020-08-19T20:22:23 MCEBuddy.AppWrapper.Base --> C:\Users\ldc76\Downloads\The 100 S07E11 20200812 [20200813-0000].mpg: Permission denied
–> Process exited with code 1

2020-08-19T20:22:25 MCEBuddy.Engine.ConversionJob --> Running custom commands
2020-08-19T20:22:25 MCEBuddy.Transcode.CustomCommand --> Engine running as service, enabling PreMetaCustomCommandUISession, since PreMetaCustomCommandShowWindow is enabled
2020-08-19T20:22:25 MCEBuddy.Transcode.CustomCommand --> Custom command parameters read ->
PreMetaCustomCommandPath =
PreMetaCustomCommandParameters =
PreMetaCustomCommandHangPeriod = 300
PreMetaCustomCommandCritical = False
PreMetaCustomCommandUISession = True
PreMetaCustomCommandShowWindow = True
PreMetaCustomCommandExitCodeCheck = False
2020-08-19T20:22:25 MCEBuddy.Transcode.CustomCommand --> No custom commands found
2020-08-19T20:22:25 MCEBuddy.Engine.ConversionJob --> Finished pre metadata custom command, source file size [KB] 3,423,865.00
2020-08-19T20:22:25 MCEBuddy.Engine.ConversionJob --> Getting show information and banner from Internet sources
2020-08-19T20:22:25 MCEBuddy.MetaData.VideoMetaData --> Extracting metadata from file -> C:\Users\ldc76\Downloads\The 100 S07E11 20200812 [20200813-0000].mpg
–> Checking for SiliconDust meta tags
–> Starting to extract payload from TS file, upto 64 TS packets will be processed
WARNING> --> Error trying to read data to TS file. Error: System.IO.IOException: The process cannot access the file ‘C:\Users\ldc76\Downloads\The 100 S07E11 20200812 [20200813-0000].mpg’ because it is being used by another process.

Any ideals as where to look would be appreciated

thanks

Larry

off top of head w/o really getting chance to investigate…the file locations getting indexed by windows search or any other indexer?
can easily lock files

Thanks. I’ll try turning it off. Perhaps if I knew what enhancements were made between 5.2 and 5.3 I could get a clue where to look. If I get a chance today I will compare my 2 laptops to see if I can discover something.

Regards
Larry

You can find the release notes here: Announcements - MCEBuddy

I don’t see any change related to ffmpeg or to this. I can’t see from these logs bug check your monitor location expert settings if you have a delay set before adding the files to the queue to prevent locked files from being sent to mcebuddy.

Goose

I check out the changes and agree that nothing seems to stand out what would cause the issue. Today by happen chance I ran the same show with two different air dates the one march one doesn’t error but the august one does on version 5.4 . Both pass on verision 5.2…

I load up the two files and log files for each version to your ftp site, there located in the ldc7675-test directory.

Maybe if you get a chance you could run them and let me know if you get the same errors. By the way thanks for looking into this, its really weird.

I ran the test on 2 identical d830 laptops and both had identical errors and passes. Have tried it on the desktop yet.

Larry

The files you uploaded are converting without any issues here with 2.5.4

2020-08-21T08:46:26 MCEBuddy.AppWrapper.Base --> Launching process C:\Program Files\MCEBuddy2x\ffmpeg\ffprobe.exe
2020-08-21T08:46:26 MCEBuddy.AppWrapper.Base --> Process arguments -hide_banner -probesize 100M -analyzeduration 300M -i “C:\Users\Goose\Desktop\News 5 20090411 [20200810-2200].mpg”
2020-08-21T08:46:26 MCEBuddy.AppWrapper.Base --> UI Session Admin Process : False
2020-08-21T08:46:27 MCEBuddy.AppWrapper.Base --> Setting process priority to Normal
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> [mpeg2video @ 00000207993c2940] Invalid frame dimensions 0x0.
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> Last message repeated 7 times
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> [mpegts @ 000002079939b140] PES packet size mismatch
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> Input #0, mpegts, from ‘C:\Users\Goose\Desktop\News 5 20090411 [20200810-2200].mpg’:
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> Duration: 00:30:59.67, start: 27431.266511, bitrate: 9147 kb/s
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> Program 3
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> Stream #0:0[0x31]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv, top first), 1920x1080 [SAR 1:1 DAR 16:9], Closed Captions, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> Stream #0:10x34: Audio: ac3 ([129][0][0][0] / 0x0081), 48000 Hz, 5.1(side), fltp, 384 kb/s
2020-08-21T08:46:28 MCEBuddy.AppWrapper.Base --> Stream #0:20x35: Audio: ac3 ([129][0][0][0] / 0x0081), 48000 Hz, stereo, fltp, 128 kb/s
–> Process exited with code 0

It also remuxes without any issues

2020-08-21T08:47:15 MCEBuddy.AppWrapper.FFmpeg --> video:1899108kB audio:116218kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 3.189370%
–> Process exited with code 0
–> FFMpeg output file size [KB] -> 2,079,602.00
2020-08-21T08:47:17 MCEBuddy.RemuxMediaCenter.RemuxMCERecording --> Original file size [KB] -> 2,076,550.00
2020-08-21T08:47:17 MCEBuddy.RemuxMediaCenter.RemuxMCERecording --> Remuxed file size [KB] -> 2,079,602.00

I think there may be a problem with your installation or with your windows setup.

Goose
Thanks now I know something is hosed on all three of my computers. It’s probably windows.

Regards
Larry

Goose

I think I found the issue. I use the same mcebuddy.conf file on all the computers. It appears there is something in this file that (5.4 ) doesn’t like for any of my tasks. I can duplicate a task and run that task and it has no errors.

I used the news% task and duplicated news5 task in the attached config file .

Give it a try and see if you see the same issue.

so I can fix the issue by duplicating all my tasks if necessary

thanks

Larry

mcebuddy.conf (16.3 KB)

Please don’t edit the mcebuddy.conf file manually. Everything can be done through the GUI, including when you upgrade MCEBuddy. There are sanity checks done when MCEBuddy upgrades and when the settings are saved through the GUI.

We have placed this warning in several places including the ReadMe file and on the discussion forum advanced settings documentation page:

PLEASE DO NOT REPLACE THE NEW CONFIGURATION FILES WITH THE OLD FILES AS PARAMETERS IN THE NEW FILES ARE ADDED/UPDATED WITH EACH RELEASE.

NOTE: As of v2.3.13 ALL configurable parameters (except FFmpegBackupRemux) in MCEBuddy.conf can be accessed through the GUI, Settings -> Expert Settings page. You DO NOT need to manually edit the mcebuddy.conf file.

You can duplicate your tasks using the MCEBuddy GUI, right click on the task and select Duplicate

Goose.
I understand what your saying. I assure you I don’t manually edit config. I have always let the program do the upgrade without my intervention on the config file. I have done the installs between 5.2 and 5.4 multiple times in testing With same results. So it appears that for whatever reason on my computers the new config construct is not being updated on my computers.
The laptops have an earlier version of my desktop config tasks that I used about 6 or 8 months ago.

Now that I know what to do to correct it. I’ll duplicate my tasks in the GUI “As always“ and delete the old ones. Want take long.
Thanks for testing my files the results led me to the solution.

Hopefully no one else has this issue.

Regards
Larry

Do note that you need to purchase a separate installation license for each computer. Please see our website for details.

Goose
I only use the desktop server for mcebuddy. The laptops were used to help validate the issue. There to slow anyway for conversions.

Finally had to rebuild from scratch with fresh new config file. Something in the old config file was creating issues with 5.4 but amazingly not 5.2.

Regards
Larry