Random failures - analyzing video information failed

In the last month I have noticed an issue where I am getting this error message “Analyzing video information failed” randomly.

I went to the ‘History of Converted Files’ and Sorted on the error message column. The first time I saw the “Analyzing video information failed” error listed was on 9/21/2017, since then I have seen the error 43 times.

When I see the files have not converted I manually add them to the MCEBuddy queue and try again. Sometimes they convert just fine but other times it errors again. I may have to do this multiple times before it actually works. There does not seem to be any rhyme or reason to why it works or does not work.

I tried to FTP logs but get error:
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

All the logs look very similar when it fails it fails after calling ffprobe.exe and from what it looks like nothing comes back thus it fails.

INFORMATION> 2017-10-21T12:17:23 MCEBuddy.VideoProperties.VideoInfo --> Supplementing Media information using FFMPEG
2017-10-21T12:17:23 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Launching process C:\Program Files\MCEBuddy2x\ffmpeg\ffprobe.exe
2017-10-21T12:17:23 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Process arguments -hide_banner -probesize 100M -analyzeduration 300M -v quiet -print_format json -show_format -show_streams -show_chapters -i “D:\Recorded TV\TempRec\MCEBuddy_Temp_Folder\working0\The Late Show With Stephen Colbert_KMOV-DT_2017_10_20_22_32_00.ts”
2017-10-21T12:17:23 MCEBuddy.AppWrapper.FFmpegMediaInfo --> UI Session Admin Process : False
2017-10-21T12:17:23 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Setting process priority to Normal
2017-10-21T12:17:23 MCEBuddy.AppWrapper.FFmpegMediaInfo --> {
2017-10-21T12:17:23 MCEBuddy.AppWrapper.FFmpegMediaInfo --> }
–> Process exited with code 1
ERROR> 2017-10-21T12:17:25 MCEBuddy.AppWrapper.FFmpegMediaInfo --> ERROR Processing FFProbe Output.
System.NullReferenceException: Object reference not set to an instance of an object.
at MCEBuddy.AppWrapper.FFmpegMediaInfo.ParseFFPROBEMediaInformation(String StdOut)
2017-10-21T12:17:25 MCEBuddy.AppWrapper.FFmpegMediaInfo -->
Video stream -> -1
Video codec ->
Duration (s) -> 0
Color format ->
Height (pixels) -> 0
Width (pixels) -> 0
Storage aspect ratio (SAR) ->
Display aspect ratio (DAR) ->
Video bitrate (kb/s) -> -1
Frames per seconds (FPS) -> 0
Video stream PID -> -1


ERROR> 2017-10-21T12:17:25 MCEBuddy.VideoProperties.VideoInfo --> Unable to read media information using FFMPEG or MediaInfo
ERROR> 2017-10-21T12:17:25 MCEBuddy.Engine.ConversionJob --> Analyzing video information failed
INFORMATION> 2017-10-21T12:17:25 MCEBuddy.Engine.ConversionJob -->
–> Performance Metrics for the Current Conversion

–> Source video duration (hh:mm:ss) -> 01:05:57
–> Source video codec -> mpeg2video
–> Source video height -> 1080
–> Source video width -> 1920
–> Pre-conversion video duration (hh:mm:ss) -> 00:00:00

–> <Start At Date/Time> <Duration (hh:mm:ss)>
–> <10/21/2017 12:07:59> <00:00:00>
–> <10/21/2017 12:07:59> <00:00:00>
–> <10/21/2017 12:08:00> <00:00:00>
–> <10/21/2017 12:08:00> <00:00:05>
–> <10/21/2017 12:08:05> <00:03:25>
–> <10/21/2017 12:11:30> <00:00:00>
–> <10/21/2017 12:11:30> <00:00:18>
–> <10/21/2017 12:11:49> <00:04:28>
–> <10/21/2017 12:16:17> <00:00:00>
–> <10/21/2017 12:16:17> <00:01:05>
> <10/21/2017 12:17:23> <00:00:02>

INFORMATION> --> Total time taken by conversion (hh:mm:ss) -> 00:09:26

I don’t know what caused this to start happening about 1 month ago. It does not happen every time, it seems very random. I have tried turning off hardware acceleration to see if that fixed the issue, it did not. Issue seemed to happen just as often so I turned it back on. I have GeForce GTX 950 and have the latest driver 385.69 but that does not seem to fix it either.

We would need a sample of the one of the original video files causing this failure. Try using passive FTP (filezille supports passive ftp in it’s settings) to upload the video file. Sometimes your firewall can block active FTP.

I still could not get FileZilla to work. It was in passive mode, I tired bypassing router to go directly thru modem, still no joy. I had to resort to using an online ftp server to transfer files though I am limited to 19MB file size.

I used the file splitter you mention in your instructions and uploaded the 1st chunk. I also uploaded several examples of logs where conversion failed (all failed logs under 700KB) and 1 log where the conversion of the same file finally succeeded (labeled The Goldbergs-Good log.zip).

Using the Goldbergs video I am using as an example was recorded using WMC and that same file failed 3 times in a row before finally converting. I did nothing to the settings of file in between attempts. All I did was manually add it to the queue after each failure. Finally all of a sudden on the 4th attempt it completed successfully.

If there is anything else I can send let me know (note I am limited to size of file I can send due to my FTP issues).


I’m guessing your firewall or router is blocking it. Try turning it off. We have no issues with folks having uploaded 20GB files.

As I mentioned I already tried bypassing my router and went directly thru the modem with no success (thus issue is not related to the router). The 19MB limit is due to the fact that I had to use an online FTP site https://www.net2ftp.com/ to upload the files I uploaded to you guys. I put those files in ftp://upload.mcebuddy2x.com/trickster/ on 10/23.

Okay so couple of things.

I couldn’t open the logs you had uploaded, something is wrong, they’re all in Mandorin or some chinese dialect (here’s what I see)

–> Starting conversion - DEBUG MESSAGES
਍䤀一䘀伀刀䴀䄀吀䤀伀一㸀 ⴀⴀ㸀 圀椀渀搀漀眀猀 伀匀 嘀攀爀猀椀漀渀 ⴀ㸀 䴀椀挀爀漀猀漀昀琀 圀椀渀搀漀眀猀 一吀 㘀⸀㄀⸀㜀㘀 ㄀ 匀攀爀瘀椀挀攀 倀愀挀欀 ㄀ ⠀圀䤀一开㜀开㈀ 㠀开匀䔀刀嘀䔀刀开刀㈀Ⰰ 䠀漀洀攀 䔀搀椀琀椀漀渀⤀ഀഀ

I used your sample chunk file but couldn’t replicate your issue. It’s working fine here, ffprobe is reading the file properly. Try using the latest 2.4.8 build of mcebuddy. If that doesn’t solve the issue, try download the latest build of ffmpeg from ffmpeg.org and replace the ffprobe and ffmpeg files in the mcebuddy installation folder with that build.

I had a very similar problem and resolved it by disabling the comskip log (verbose=0). Once the size of the log grew very large, it would take a lot of time for each new line to be written to the log file, and MCEBuddy would kill the comskip task before it could complete.

I posted here:

I don’t know why the files all got converted to Chinese… Odd. I went and zipped up all the log files and placed them out there in a file called. ‘Log messages all zipped up.zip’ Maybe they will be readable now. I was able to download them again and did not see the Chinese chars this time… I use MCEBuddy a great deal and normally everything goes as is should but this issue will happen randomly. The same file will fail once or sometimes 4 times in a row but then all of a sudden the next time I try with the very same file it will work. I am no doing anything special when it works it just decided to work. I have the newest version of MCEBuddy and out of the 10 items I converted on 11/04 two of them failed but I took each one and manually added them back and they worked on the second attempt. Like I said very Odd behavior.

The log corruption maybe caused by the round about FTP issue.

From what you’re saying and from what I can see in the logs it appears that randomly in between when MCEBuddy tries to access the file it can’t seem to access it. From the logs it appears that this is happening just after a new file is created by MCEBuddy (e.g. after conversion or merging the commercial free segments etc).

One thought crossing my mind is some other software like Antivirus or Windows Defender is scanning/blocking the file which could be causing the issue. Try to disable your antivirus or any other software that’s monitoring files in the background, I suspect that’s what causing these random failures.

Technically there is no difference between the 1st run and the 100th run from MCEBuddy, the only difference (which we’ve seen the past) is third party software like antivirus blocking access to the files which causes failures. Maybe best to exclude the temp folder from antivirus scanning.

I just thought I would provide an update:

I did as you suggested and added an exclusion in AVG for the MCEBuddy temp directory and waited to see how things went. I put in the exclusion on 11/06/2017 and since then according to the logs MCEBuddy has 115 entries in its history file. 109 of the 115 the conversion took place just fine no errors. 6 of the 115 times it ran into the ‘Analyzing video information failed’ error. It is only errors 5% of the the time which is not that often overall but it seems to still be happening even when I have AVG ignore the temp dir.

I probably can live with the 5% error rate but it is just irritating and a bit frustrating not being able to understand why it seems to randomly error then after future attempts (without out me changing a thing) it decides to work. I understand when you say ‘Technically there is no difference between the 1st run and the 100th run from MCEBuddy’, I agree with that, I don’t see any difference either… Too bad 5% of the time reality does not agree with our logic. :slight_smile:

I do appreciate you trying to help find a solution. Maybe it will go away one day on its own just as it showed up one day.

The 5% of the time it’s a third party software that’s interfering with your setup. Run it on a clean install of windows without third party software and see if you can replicate the issue.

The problem isn’t MCEBuddy, the hard task you have is figuring out which third party software is interfering with MCEBuddy. No easy task.