Someway to test MCEBuddy2x before unleashing it on my entire Plex video library?

I am 2 days old using MCEB and am concerned about destroying my Plex media directory. Also I know nothing…

My primary goal is to convert TS files to MP4 files after Plex records them. Plex does not handle TS gracefully. I don’t need commercial skip.

Is it possible to use the GUI and point it to a dummy folder inside my Plex media folder and then just run it from the GUI?

Then insert the post processing script in Plex and repeat the same task.?

I followed this post and think I understand it.

Please be gentle I am very wet behind the ears.

Thanks, Fred

Welcome to the community. You’re on the right track. Also check out this topic and the Plex section for more tips: Plex - MCEBuddy

To answer your question about testing it, just redirect the output directory in the Conversion Task settings to a different folder and see how it works out. If you’re happy set it back to the original setting you had.


I jumped in this morning and set it to just one folder and it did not work as expected.

I started a new post unfortunately. Not sure how to get the new one over to this one. Maybe a moderator can combine them.
Here is the link to that post.

If you can find time please look at it.

Thanks, Fred

Hi Fred and welcome to MCE.
The key is getting the initial setup working, then you can tinker with the MCE processing.

Here’s my initial setup. I originally purchased (years ago) a WD MyCloud PR2100 NAS (network storage) and upped it to 12 TB. I’d originally hoped to use this as my Plex Server. After using it for a couple years and finding it really doesn’t have the guts that I’d hoped, I bought a computer with an i5 CPU and added a 2 GB drive for storage. I call this my PlexServer which also houses the MCE software.

I’ve added several folders to the PlexServer 2nd drive called:
DVR Recordings - (Plex saves recordings to here)
MCE Buddy Temp - (Set this as your MCE temp folder)
MCE Buddy Out - (where MCE saves processed vids)

I could have kept these on the main c: drive but wanted them kept separate for speed purposes.

In Plex, I set my DVR target folder for all recordings to the DVR Recordings.
Monitor Location

Don’t forget to have it “Monitor subdirectories” and the search pattern .
Then click Expert Settings:
exclude *.grab The grab folder is where the actually recording takes place and the file gets moved out of this folder when recording is complete.
Expert Files

Once you’ve done the initial setup, take one of your 1/2 hour shows from where ever you are storing and use it as your test dummy. Copy and paste the .ts file to your DVR Recordings folder, wait a minute and let MCE do its thing. If you don’t like the result, delete the creation the MCE saved the the MCE Buddy Out folder and tinker with the settings.

I personally like how MCE handles the commercial removal better than Plex. And it converts from .ts to MP4 or other formats nicely, so I just let MCE do it’s thing. As for conversion tasks, I have 4 different ones. I like the option of subtitles which I use for movies and some TV shows. But recordings such as baseball and reruns of Seinfeld, I don’t need them. The old Twilight Zone series can be lesser quality and some I choose to leave in .ts format. As for quality, I use MP4 Normal most of the time since the MP4 High Quality takes so much longer.

Now let’s talk about final location. Once you get the outcome you are looking for with the video, you can change the “Out” folder to your shared Plex folder but I choose not to. My Plex shared folder is on the WD drive and it’s very neatly arranged so I can find things easily. I have separate folders for Music, TV and Movies. Inside each of these are folders for each series or type of show, ie. Disney, Back to the Future, Seinfeld, Big Bang. So every so often, I go into the “Out” folder and “cut/paste” into the specific folders. Because of this, I added the “Recordings” and “Out” folders to my Plex library. Once I’ve cut and pasted, Plex recognizes they’ve been moved.

With that being said, I’m not sure why you need the post processing script.

I have reached that conclusion, finally. :slight_smile:

Would you please pop a copy of your script in a reply to me.
I will feel more comfortable.

Thanks, Fred

Hey Fred. I should have sent these in the last reply. Most of the settings I’ve done are by trial/error and figuring out what things do by hovering over the choices and reading the explanation. So here you go. If you need other help, feel free to reach out again and I’ll try.

The following settings are for my movies and everyday shows that I want subtitles for. At the current time, these are running on my new desktop that I just bought which is loaded for bear. It has an i7 processor with 16 GB ram and an SSD drive. I mapped a drive to my \PlexServer\E: drive so all my vids end up in one place before I move them to WD server that houses all the actually movies, tv series, music. All of what you see here I copied from my Plex Server because I just wanted to see how much this new computer would handle.

Just in case you have not yet worked with the “Selection Filters: File Name”, let me explain what I’m doing there.

.;~MLB*;~Seinfeld*;~Mash*;~The Twilight Zone (1959)*

. means to convert any file with any extension
; allows you to add more commands
~ do not convert the following (any file starting with MLB)

So this line tells the MCE to use “Plex Conversion” for any files except MLB, Seinfeld, Mash & Twilight Zone.

Why do I have this? I don’t want subtitles for MLB, Seinfeld or Mash so I have another conversion (on my Plex Server) and I wanted 3+ hour show MLB to be handled quickly.

There’s only 1 issue with what I’m doing and have yet to figure it out…but I’m trying. When a movie is recorded, commercials removed, changed to MP4 and subtitles added, for some reason I’m getting 2 different sets of subtitles that both can be turned on/off separately in Plex so it’s not a big issue except I’m sure it’s taking longer to create both. It actually creates a separate .SRT file. I just copy them both into the same folder. I can live with that for now.

These settings are