Sleeping before conversion finsihed

(Mike) #1

sometime within the last few version MCEBuddy no longer seems to finish processing a conversion before the computer goes to sleep. I have always had turn of sleep enabled. Here’s the strange thing, it is doing the same thing on 2 system, however it ONLY seems to happen on recordings from my HDPVR2 and not from the WinTV Quad on either system. My conversion log from the last time it happened attached. Thanks in advance

SwampPeople-S10E15-VoodooPython-35895966-0.ts-Convert to MP4-2019-05-24T07-34-38.0890139-05-00.log (765.4 KB)

(Goose) #2

There hasn’t been any change to that module for a very long time. It’s possible some recent windows update/settings may be causing ignoring the no sleep request.

When MCEBuddy is actively converting, it informs the OS to not sleep, but finally it’s upto the OS and it can choose to ignore the app. I think Windows now has a setting which can make it ignore the apps’ request and still allow it to sleep. You may want to check your windows sleep/power settings.

Also all sleep/power events/requests are logged in the mcebuddy.log file.

(Mike) #3

thanks wingman, I took a look at that file and see nothing about sleep other than the setting, do you see anything in here that might be causing it? Also can I request a flyby?mcebuddy.log (3.3 MB)

1 Like
(Goose) #4

The log looks fine at the outset, I see that MCEBuddy is requesting the system to not sleep and resume normal operations when there are active conversions and conversions are finished respectively

2019-05-24T13:04:09 MCEBuddy.Engine.Core --> Starting new conversions, preventing system sleep
2019-05-24T13:11:29 MCEBuddy.Engine.Core --> No conversions running , allowing system sleep

You’ll need to check the Windows logs to see what’s going on. The first step would be to see when the system is going to sleep. Typically when it goes to sleep it should also send MCEBuddy the request. If you click on Events link on the main window top right corner it will pull a list of the windows event log entries made by the mcebuddy engine. Copy and paste those logs around the time you saw the system sleep (I’m guessing it would be between the two timestamps in the logs I extracted above).

image

From there you can open the Windows Event Logs around the time and see if you can gleam more information about why Windows went to sleep (did some application send the command or was it just the internal sleep timer which expired). If it’s inconsistent like you described in your first post, I suspect some application may be sending the sleep command.

(Mike) #5

here’s MCEBuddys log at the same time windows puts it to sleep:

Information 5-Jun-2019 11:39 PM
MCEBuddy OnPowerEvent called by System, Event -> Suspend

The system is entering sleep.

Sleep Reason: System Idle

but 1 sec later windows shows this:

The system has resumed from sleep.

(Goose) #6

That looks like Windows is ignoring the request from MCEBuddy to prevent sleep. Check your windows power settings, there an override option in there somewhere which allows you to configure how windows handles sleep (never, idle, critical etc). Unfortunately this is a windows setting issue and I’m guessing something changed somewhere either during a windows update or accidentally

(Mike) #7

strange, windows pays attention to SageTV for waking for recordings and staying awake until airing is finished, it is only ignoring MCEBuddy it seems

(Goose) #8

It maybe a timing issue, MCEBuddy tells Windows to stop sleeping and another app is sending a signal saying it okay to sleep after MCEBuddy has sent the signal.

(Mike) #9

I think I fixed it, thanks for steering me in the right direction, number 4 here:

https://www.auslogics.com/en/articles/windows-10-going-sleep-mode-minutes-fixed/

seems to have worked for me

1 Like