Settings for Unaltered HEVC ATSC 3.0?

I’ve been using MCEBuddy for a while. HEVC ATSC 3.0 just went LIVE today in my market.

I was wondering what settings to use for these channels? The container recorded is .TS with H.265 Video AC-4 Audio. I would like to just remove commercials but leave the video/audio untouched.

Edit: I have tried a few different settings and after MCEBuddy is done running it’s task, nothing was changed? It seems 2.5.7 (maybe all?) are incompatible with the new ATSC 3.0? Is it the AC4 audio that throws it off?

Using an “unprocessed” profile should work. Example below.

[MKV Unprocessed]
Description=No video processing, just changing the container to MKV.  
ffmpeg-general=-threads 0 -v verbose
ffmpeg-video=-c:v copy -map 0:v -sn
ffmpeg-audio=-c:a copy -map 0:a
ffmpeg-audioac3=-c:a copy -map 0:a

This profile should simply copy both audio and video. In this case it puts it in an MKV container. If you want to keep it as a TS just change the ffmpeg-ext=.mkv to ffmpeg-ext=.ts.
If there is an issue with AC4 then it’s an issue with ffmpeg.

I ran the MKV Unprocessed profile that you suggested. It did it’s thing and came out exactly the same as before it was ran. No commercial ripping.

Can you post your conversion log? That’ll hopefully shows us what’s going on.

Can you take a look at these please and let me know what’s going on? Thanks

Wheel of Fortune S39E157 Home Sweet Home.ts-ATSC3-2022-04-20T11-09-09.log (217.9 KB)
Wheel of Fortune S39E157 Home Sweet Home.ts-ATSC3-2022-04-20T12-22-27.log (217.2 KB)
Wheel of Fortune S39E157 Home Sweet Home.ts-TS Unprocessed-2022-04-19T19-47-20.log (220.0 KB)
Wheel of Fortune S39E158 Home Sweet Home.ts-ATSC3-2022-04-20T19-01-40.log (216.1 KB)

It looks like it’s trying but timing out. Here is the section of the log from “Wheel of Fortune S39E157 Home Sweet Home.ts-ATSC3-2022-04-20T11-09-09.log” that is of note.

2022-04-20T11:13:02 MCEBuddy.CommercialScan.Scanner --> EDL: Minimum segment size 4 seconds.
--> EDL Setting (ForceEDL) -> False
--> EDL Settings (ForceEDLP) -> False
2022-04-20T11:13:02 MCEBuddy.CommercialScan.Scanner --> EDL: Initial skip seconds adjustment 0 seconds.
INFORMATION> 2022-04-20T11:13:02 MCEBuddy.CommercialScan.Scanner --> Scanning commercials with Comskip
2022-04-20T11:13:02 MCEBuddy.AppWrapper.Comskip --> Launching process C:\Program Files\MCEBuddy2x\comskip\comskip.exe
2022-04-20T11:13:02 MCEBuddy.AppWrapper.Comskip --> Process arguments  --output="\\Superserver\Media\Temp\Comskip Temp\working0" "\\Superserver\Media\Temp\Comskip Temp\working0\Wheel of Fortune S39E157 Home Sweet Home.ts"
2022-04-20T11:13:02 MCEBuddy.AppWrapper.Comskip --> UI Session Admin Process : True
2022-04-20T11:13:02 MCEBuddy.AppWrapper.Comskip --> Starting process as a UISession process with Admin privileges. This requires atleast 1 user to be logged into the system (remote desktop or locally)
2022-04-20T11:13:03 MCEBuddy.AppWrapper.Comskip --> Setting process priority to Normal
INFORMATION> 2022-04-20T11:13:03 MCEBuddy.AppWrapper.Comskip --> Process priority changed to Normal
ERROR> --> No response from process for 300 seconds, process likely hung - killing it
ERROR> --> Process hung, killing process
ERROR> 2022-04-20T11:18:05 MCEBuddy.CommercialScan.Scanner --> Comskip failed
ERROR> 2022-04-20T11:18:05 MCEBuddy.Engine.ConversionJob --> Advertisement scan failed

This seems similar to another reported issue on the comskip support forum

Looks like you’ll have to wait for a comskip fix. Otherwise you’ll have to play around with converting the audio to a comskip supported format then try removing commercials.

1 Like

Ok thanks for looking at this for me. Is there a “best way” to let MCE/Comskip know about this?

Possibly because you’re using a network path for a temp folder. Try using a local drive

Temp Working Path → \\Superserver\Media\Temp\Comskip Temp

Everything is a network path. The monitoring locations, temp files, and destination locations. Thanks for checking in but that’s not the issue.