Missing Add buttons under MCEBuddy Settings

Hello,

Relatively new user who is using Donator 2.5 (Beta 4).

I have run into this issue twice now. If I go into Settings and delete all of the Monitor locations and try to start over, I cannot, because the Add button is disabled. The same thing for the Conversion Tasks Add button. I can only Delete or Change the current Conversion Tasks. But I cannot add a new Monitor Location or Conversion task. I have tried restarting the service to see if that makes a difference, but it does not.

Previously, when this happened, I did a full uninstall and reinstall and that restored the Add buttons. But now I have done it again and can’t find any other forum posts about this happening to other people. I don’t want to keep reinstalling the application in order to restore my ability to add new items to either list. I have attached a clean copy of the mcebuddy.log file with one start/stop of the service. Maybe there is a clue here. What must I do to regain the Add buttons without a full reinstall? Does the currently released version also do this? I haven’t tried to use it.

Thanks in advance for any assistance or advice.
-Joe

Here is a screenshot of my settings page. If I also delete the one Conversion Task, then I have no way to add any new item to either list.
No_Add_Buttons

Here is my mcebuddy.log file:
mcebuddy.log (42.3 KB)

I"m having trouble trying to replicate this. Can you attach your mcebuddy.conf file and hopefully that will help me replicate the issue. If you have any specific steps to help replicate how your got here would be useful.

Thanks @Goose. Here is the mcebuddy.conf file from this installation:

mcebuddy.conf (3.4 KB)

I love the phrase, “how you got here”. I got a laugh out of thinking of my life. But I knew what you meant.

It was too simple, really. I wanted to start over with a new Monitor location and so I deleted the single entry in that list. Once I did that, both Add buttons became disabled. I know from this happening on the same PC before, that uninstalling and reinstalling would restore the Add buttons.

I also have installed the same MCEBuddy 2.5b4 version on a Windows Server 2019 VM and deleting all of the Monitor Locations on that installation doesn’t change the appearance or functionality of those Add buttons. So, that is probably the correct behavior. But on my Windows 10 laptop, I don’t seem to have a way to restore the Add buttons. I know that I could have reinstalled it, but wanted to wait to see if this was a bug or something my Window 10 was doing wrong before going that route.

I mainly use and plan to use the Windows Server 2019 VM to run MCEBuddy and was only using the laptop install to test out various tweaks before updating the “production” installation. So this is not in any way, critical.

Thanks very much!
-Joe

The only time the Add button gets disabled is when you MCEBuddy GUI is connected to a remote engine and that’s what I suspect is going on. When you reinstall it reverts it back to the local engine.

With remote engines you can’t create a task since the paths’ are not valid. Ideally you should only be using a remote connection to an engine to view the status and start/stop the engine.

Well that makes perfect sense. I did connect at one time, remotely to the server. However, I then [thought] I went into the server settings and restored it to 127.0.0.1 when I manually started the server on THIS PC. I will check this right now.

Try localhost instead

Thank you. [SOLVED]

I did that and the Add buttons immediately returned. Thank you for this advice. I guess I just thought that 127.0.0.1 would be the equivalent of ‘localhost’.

You can click on the Defaults button to restore the default settings in the remote engine page