I got a new router (Google Nest) and now MCE is unusable

“The MCEBuddy service is unavailable. Pleas start from Windows control panel or check engine connection.”

The “MCEBuddy2x” service is running.
I’ve uninstalled and re-installed. I also restarted the PC in between steps and in general, restarting.

Another computer on the network that used to run MCE is also having the issue.

The IP for the NAS has changed. How do I fix this?


Check your firewall, it’s probably blocking the ports used by MCEBuddy (default port is 23332). Start by disabling the firewall on your router/computer (both), and then enable them one by one to see which one is blocking the comms.

Thanks for the response. I’m looking at the router app and it has port forwarding. it asks me to pick a device. I pick the one mcebuddy runs on and then it asks for an internal port and external port. I tried 23332 for both, but it doesn’t seem to help. I disabled my firewall too.

If you’re running MCEBuddy locally on your computer and not using the remote client then there some app/firewall on your computer that’s blocking the ports.

It was a bad installation causing the issue.