Hdhomerun | TV Shows | Movies | Sports - Processing

Okay - as always i’m sure the problem is on my end. I am having trouble working out where I went wrong.

The SiliconDust HDHomerun PVR service records to \server\hdhomerun\

They have 3 categories with paths that they use which I cannot change.

\server\hdhomerun%Series Name%\Teen Titans Go! S01E06 20130619 [20180328-1130].mpg
\server\hdhomerun\Movies\Movie Name.mpg
\server\hdhomerun\Sporting Events\MLS Soccer - New York City FC at New England Revolution 20180324 [20180328-1000].mpg

the only things that get their own folder in that directory are TV shows. All movies and sporting events are dumped into the same folder, this is fine with me by the way since movies and tv shows are post processed correctly. The issue I am having is even though I have the “Sporting Events” folder set to be ignored.

I have the following configuration

Monitor locations

  1. \server\hdhomerun\ - set to exclude the following “Movies; Live TV; Sporting Events”
  2. \server\hdhomerun\Movies\ - no exclusions as it only monitors files within the \Movies subfolder
  3. \server\Sporting Events\ - no exclusions as there are only sporting events here.

Conversion Tasks

  1. Movies - works as expected, strips commercials, relocates the folder to \server\media\movies\ for import into my emby/kodi/plex libraries.
  2. TV Shows - Works as expected for TV Shows and imports into my \server\media\tv shows\show name\season xx\ folders.
  3. Sporting Events - appears to be ignored as it is being superseded by the tv shows conversion tasks.

The problem I appear to be having is there is no exclusion option for conversion tasks like there is for monitoring.

End goal is to just have MCEBuddy monitor and strip Sporting Events and delete the original files and replace with the new and improved one. The issue I am having is that the sporting events are being imported into my \server\media\tv shows\event name\ season\event name.ext

is there a way to force the monitor locations to exclude a path as well?

sorry for wall of text - figured I would try to be descriptive as possible. please let me know if there is anything else I can provide.

thank you in adv

Every conversion task will be fed files from every monitor location unless in the Conversion Task -> Expert Settings page you’ve “selected” specific monitor locations to link to that conversion task.

@Goose - yes I have done this, the problem is that the “Sporting Events” folder falls within the TV Shows folder. I have the TV Shows monitor location set to ignore the “Sporting Events” folder but the conversion task for TV shows continues to monitor the “Sporting Events” folder regardless. I can provide screenshots if you like.

It sounds like a configuration issue somewhere, either the metadata isn’t matching or the filters aren’t setup right.

@goose - so what would you like to see to help me correct this if that is in fact the case?

Check your mcebuddy.log file, search for the filename which “should” have been picked up for processing and from the logs you should be able to track down what’s going on and why the file wasn’t picked.

heres the conversion log - see the “Sporting Events” folder in the exclude list?

–> Task -> HDHomerunPVR
Profile -> MP4 Normal
Source File -> \qnap\hdhomerun\Sporting Events\UEFA Champions League Soccer - Besi

and the monitor path config

SearchPathExclude=Movies; Live TV; Sporting Events

Unfortunately this doesn’t help, you’ll have go through the log and look for specific filenames and the messages against those files

my problem is that it’s even getting this far. that folder is on the excludes list.

I’ve replicated it and it’s working here, your configuration file should look like:

SearchPathExclude=Sporting Events;Live TV

Notice there are no “spaces” before and after the ; in the exclusion list, every character counts

testing now.

@Goose - looks like the Exclusions are now blocking the other conversion tasks. I am still doing more recordings to test.

@Goose - I confirmed that the exclusions from the first monitoring location are blocking the conversion process of the two other items (Sports), (Movies) by removing the exclusions and rescanning.

Movies;Live TV;Sporting Events

1 Like

I use SD HDHR PVR also. You’ve over-complicated your setup.

  • Set the monitor to the base HDHR directory. Set MCEBuddy to not touch any files until 5 minutes after last modification (to not try to convert live TV).
  • HDHR automatically puts the guide categories for Sports/Movie/Other. There is no “series” or “special” or “other” category.
  • The order of the processing rules is important.
  • Process movies first. No matter where they record, MCEBuddy gets the category from the metadata in the file. Use a custom file rename - I like title.release-year.
  • Process Sports next. Same deal. Use a custom file rename - I like title.air-date.air-time.
  • Process Series/Specials LAST. Same deal, but you need a custom renaming here to test for a series, and use a custom series rename if true, and a custom specials name if not. You have to do this because there is no separate “series” category from “other”.
  • Use the custom filename to move everything to the right place. I move mine to where Plex looks for them.

Then you won’t need all of the exclusion stuff. I’ll help if there’s tweaks I’ve missed. Ask.

@mike808 - first off thank you for the detailed reply. I have deleted my configuration and recreated one based on the above suggestion. I just tested now by recording an episode of Friends and all 3 conversion tasks are now running against the episode.

Sorry to hear that it is triple-dipping. I’ll review all of my settings and post here each step so you can enjoy hands off operation like I do.

Check the Expert Settings Monitor locations, that’s one place to limit which locations runs with which task.

@Rboy - thanks for the reply. According to @mike808 with his config I don’t require exclusions in the monitor locations. I believe you have replied to me in the past in a previous thread about this same issue once before.

Here’s my folders:
Here’s my settings:

Hope this helps. Feel free to re-use the images in a how-to.


If you’d like to make a HowTo I’d be happy to make it into a Wiki