I am using HDHOMERUN DVR to record shows. It places a recorded show into a specified location (in my case, a WDCLOUD NAS drive, \WDCLOUD\HDHomerun) and inside a folder it creates with the show’s title. MCEBUDDY processes the shows and places new file in the HDHomerun folder. Unfortunately, HDHOMEUN DVR now displays 2 identical shows: the original from the \HDHomerun folder- and the commercial free under the WDCLOUD (it is not placed in the HDHomerun folder). The solution I prefer is to Archive the original file in a completely different folder (not the HDHomerun folder) so then not be seen by the HDHOMERUN DVR watched location. Ideas on how to do this? Or a better solution? Thanks

See if this helps: How to prevent HDHomeRun from recording shows

Thanks so much or your prompt reply. First, I know little about programming- and even less about scripts. In other words, I really don’t know what I’m doing!!But I am trying to learn.

First, I added to folders to my C: drive: PartCopy and ArchivedFiles

Second, I modified the MakeStub file- and placed both it and PartCopy files into C:\PartCopy folder

MakeStub script:
PartCopy %1 %1.tmp %2 %3
move %1 C:\ArchivedFiles
move %1.tmp %1

Thirdly, I finally found the profiles.conf file, selected the profile that I am using (HDHomerun Unprocessed) and added the lines (in italics) as shown below:

[HDHomeRun Unprocessed]

Description=Used to remove commercials and create a SiliconDust HDHomeRun compatible MPG file while keeping original video/audio quality and format. It does not remove black bars, resize the video, deinterlace or select audio language.

ffmpeg-general=-threads 0
ffmpeg-video=-vcodec copy -f mpegts -map 0:v -sn
ffmpeg-audio=-acodec copy -map 0:a
ffmpeg-audioac3=-acodec copy -map 0:a
PostCustomCommandParameters="%sourcefile%" 0d 100000d

But, nothing happened. The original file remains. I am guessing that the batch file never started. It does take up to 30 minutes for MCEBuddy to do its thing- but I assume that is accounted for in the script.

Please take a quick look- and let me know what I did wrong. Thanks for your time.

That link basically keeps a stub of the original file so that it didn’t take up space and also prevents HDHR from re-recording the same show.

In your case, have you configured MCEBuddy monitor task to delete your original file? That could be one reason why HDHR is showing both files.

You could also have MCEBuddy just replace your original file with the converted file after conversion. Leave the destination folder empty in the Conversion Task (this puts the converted file back into the source folder) and also uncheck the Rename option. This you won’t have two copies of the same recording

Thanks, Goose. I used both your suggestions and the double listing has been solved.

I’m not sure if this question is MCEBuddy- or HDHomerun Record issue. When a show starts recording using the HDHomerun GUI, a new folder with thumbnail is created for each series. On the other hand, in the process of moving previously recorded shows from WMC (.WTV format), I copy it to the watched NAS location, MCEBuddy picks it up, removes commercials and converts to .mpg file. But files are not put into a folder (I really don’t care about this), and this show is shown in HDHomerun GUI as a grey folder with no thumbnail. If a show is recorded in both ways (MCE and HDHomerun), there will be 2 separate listings in HDHomerun RECORD- one with thumbnail- one with grey only. Is there a way to add a thumbnail to a converted .wtv file?

Setup a profile just for processing .wtv files and have MCEBuddy place the files (using the rename feature) in \WDCLOUD\HDHOMERUN\%showname%\%filename%

I think thats the syntax. The tags might be off, but you get the idea.

You can also create a folder \WDCLOUD\MCEBuddyArchive and make that your archive directory to keep the original file until you’re comfortable turning off keeping archives or scheduling a cleaning of the archive folder whenever you want.