Hardware usage - low %

I am trying the latest trial version, and I have a question about the general usage.
In converting a wtv file to mp4, using nvidia hardware encoder, it doesn’t seem to be using it at the maximum capability. Is that normal?
More precisely the usage is:
CPU 10-33%
GPU 12% - Video Encode (nvenc)
GPU 6% - CUDA cores
Network 5.6 Mbps (from 1 Gbps)

What codec are you converting to? I believe you’re going from h264 to h264…

I think that WTV is MPEG2 (HD on FIOS cable TV) to H264. It’s the default WTV profile.

I might do something wrong. If I choose not to remove the commercials, the resulting files are bigger than the originals. Seems the that “Quality” of the h264 encoder is 10… hmmm

2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] job configuration:
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] * source
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + D:\Temp\working0\Airplane!_BBCAHD_2019_06_07_18_59_00.ts
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + title 1, chapter(s) 1 to 1
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] * destination
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + D:\Temp\working0\Airplane!_BBCAHD_2019_06_07_18_59_00-converted.mp4
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + container: MPEG-4 (libavformat)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] * video track
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + decoder: mpeg2video
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + bitrate 200 kbps
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + filters
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + Decomb (mode=7)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + Denoise (hqdn3d) (y-spatial=3:cb-spatial=2:cr-spatial=2:y-temporal=2:cb-temporal=3:cr-temporal=3)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + Output geometry
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + storage dimensions: 1920 x 1080
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + pixel aspect ratio: 1 : 1
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + display dimensions: 1920 x 1080
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + encoder: H.264 (NVEnc)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + quality: 10.00 (CQ)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + color profile: 1-1-1
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] * audio track 1
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + decoder: English (AC3) (5.1 ch) (384 kbps) (track 1, id 0x100)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + bitrate: 384 kbps, samplerate: 48000 Hz
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + mixdown: 5.1 Channels
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + dynamic range compression: 2.500000
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + dither: triangular
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + encoder: AC3 (libavcodec)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] + bitrate: 384 kbps, samplerate: 48000 Hz
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] sync: expecting 218380 video frames
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 24 started (“Audio Synchronization”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] encavcodecInit: H.264 (Nvidia NVENC)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] encavcodec: encoding at rc=vbr 10.00
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] encavcodec: encoding with stored aspect 1/1
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 0.00 %[19:15:35] Writing Metadata to output file…
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 25 started (“Muxer”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 26 started (“Reader”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 27 started (“Audio decoder (libavcodec)”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 28 started (“Video decoder (libavcodec)”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 29 started (“Video Synchronization”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 2a started (“AVCodec Audio encoder (libavcodec)”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 2b started (“FFMPEG encoder (libavcodec)”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 2c started (“Muxer”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 2d started (“Decomb”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [19:15:35] thread 2e started (“Denoise (hqdn3d)”)
2019-12-21T19:15:35 MCEBuddy.AppWrapper.Handbrake --> [mpeg2video @ 000000000770cb00] Application has requested 17 threads. Using a thread count greater than 16 is not recommended.

The file size is related to the Quality settings, so it’s not related to the thread scope itself.

So… why is the GPU and CPU usage so low during video conversion phase?

Depends on the video filters being used in the profile and the hardware capabilities. Not all hardware support all filters so it ends up using the CPU for that processing activities. Remove all filters from the profile if you want to use more hardware (at the expense of quality). See these topics:

Well, OK, I can see how filters can impact that, since they are not processed by GPU. I don’t have filters that I know of, but I have to look deeper into that, I have selected the default profile for Convert to MP4 in WTV container.

Anyway, if the CPU was the bottleneck, why isn’t used at 100%? I have more cores that most computers (16 physical, 32 virtual with HT), is this a scaling issue? Is the software limited to a certain number of cores?