Getting "Conversion Failed" errors again

For whatever reason, I’ve started to get “conversion failed” errors again.

Graphics Drivers haven’t been updated, and MCEBuddy is running from the command line vs as a service.

Logs of the last failure:!AipRNNbyPsCgn8Al0fuq7Y3lhW4hig?e=HM6hax

I just got another - FWIW, if I transcode the file manually, it works fine. Here’s the log:!AipRNNbyPsCgn8AoC0kEFvnBF9u5Iw

I’m wondering if the script I’m using throws errors when it’s invoked from Plex. Here’s the script:

@echo off
C:\Progra~1\MCEBuddy2x\MCEBuddy.UserCLI.exe --command=engine --action=start 
timeout /t 2 /nobreak > NUL
C:\Progra~1\MCEBuddy2x\MCEBuddy.UserCLI.exe --command=addfile --action=%1
timeout /t 10 /nobreak > NUL
for /f "delims=" %%o in ('C:\Progra~1\MCEBuddy2x\MCEBuddy.UserCLI.exe --command=jobstatus --action=%1 --quiet') do set status=%%o
if %status% == "not present" (
) else (
	timeout /t 2 /nobreak > NUL
	goto loop

Thanks! Will.

Update - I think I’ve got it solved. Because I already had MCEBuddy running in Command Line mode, the “command=engine --action=start” was erroring out.

When I remove that line, it works perfectly. Hope this helps someone :slight_smile:

Or not. Got another failed conversion. Logs:!AipRNNbyPsCgn8Ap8S4FkxkZmHiZ2w

I’m stumped. Any help is appreciated!

Your graphics driver appears to be having an issue while initializing. Looks like there’s a memory leak:

2019-07-08T21:11:38 MCEBuddy.AppWrapper.FFmpeg --> [hevc_nvenc @ 0000020a974c89c0] OpenEncodeSessionEx failed: out of memory (10)
2019-07-08T21:11:38 MCEBuddy.AppWrapper.FFmpeg --> [hevc_nvenc @ 0000020a974c89c0] No NVENC capable devices found

Try to reboot your system, if it starts working then it your graphics driver has a slow leak which over time causes it to run out of memory. Maybe try downgrading to a older/more stable version.

I remembered I’d pulled a dev build of FFMpeg - I tried replacing it with the 4.13 release and haven’t run into any issues yet.

I’m running the studio version of the NVidia drivers - they’re supposed to be more stable, but maybe I just need to find a config and stick with it!

Thanks for the help!

1 Like

After getting another round of errors, I downgraded to the NVidia 4.19x drivers - no issues since then.

One thing that’s puzzling to me: I’ve run 90+ files through the UI and haven’t run into an issues using the same configuration and drivers. Why would using the UI not express the memory issue, while the command line / script invocation does?

Thanks! Will.

Do you have the link to the drivers so I can put it in the sticky?

Did you change the running mode of the engine? The only time you may see a difference is if the engine is running as a service vs as a command line engine. This is because of the way windows starts ffmpeg. In kernel context the graphics drivers behave differently vs in user context. This is a limitation of the windows/driver architecture.
Graphics Hardware API are typically designed for User context (eg games or design applications which run from user context). Most kernel apps don’t use graphics hardware acceleration APIs (because they don’t have native UI’s) so until Windows 8 the kernel didn’t offer those graphics API’s to apps and even after windows 8 and most graphics vendors don’t bother testing them properly in kernel space.

Still getting errors, but I think it might be due to switching back to the service model vs command line. Here’s the link to the legacy driver: NVIDIA DRIVERS NVIDIA Creator Ready Driver

Have you tried using 353.9?

Win 7/8.1 -
Win 10 -



Since downgrading to the 4.19 drivers above and running the command line engine, no issues. Thanks! Will.

1 Like

Just a FYI note about Nvidia cards and multiple simultaneous conversions: