Existing Subtitles and how to keep them?

So i start out with an mkv which when i start in Plex shows the subtitles im guessing from within the file as there are no SRT files in the folder with it. When i run MCE on it, its looks and plays great but no matter what i do, it doesnt keep them in the file like that. I tried exporting to .srt but for some reason after it does that Plex doesnt recognize the srt file and wont allow me to select it after i start up the stream. What is best practice for this? I’m lost lol. I am converting subbed anime btw.

Forgot to add my logs for it. First one has createsrt enabled and worked, but Plex wont see the srt. The other is just leaving it alone, which i would have thought would have kept them inside the file? I also tried using the “Add subtittles” box. It didnt change anything.

Goblin Slayer - S01E01 - The Fate of Particular Adventurers.mkv-AnimeConversion-2020-04-23T12-01-37withcreatesrtenabled.txt (1.3 MB) Goblin Slayer - S01E01 - The Fate of Particular Adventurers.mkv-AnimeConversion-2020-04-23T12-33-55justleavingitalone.txt (1.1 MB)

You haven’t enabled the option to embed the subtitles back in to the converted file:

Embed Subtitles -> False

I am 99% sure i tried that, but im having another go at it and if it doesnt work, ill attach the logs. Thank you!

No dice. Logs are attached. Thanks for all the help Goose!

Goblin Slayer - S01E01 - The Fate of Particular Adventurers.mkv-AnimeConversion-2020-04-23T14-38-06.log (1.2 MB)

Why did you disable subtitle/close caption extraction? So it won’t try to extract any subtitles from the file and hence nothing will be added back the end of the conversion.

Closed Captions ->

You need to enable both options, Extract subtitles and Add subtitles.

I was just checking what you told me outside of the default settings. Go easy on me man, in my mind it doesn’t make sense to extract them then turn around and add them. I don’t have a ton of experience on this. Running it now with both checked.

Both checked, Plex now shows there are subtitles called “(MOV_TEXT)” but they dont appear. When i play the original, they appear and Plex says “English (ASS)” and they show perfectly fine. Sorry to be a pain Goose. And thanks again.

Goblin Slayer - S01E01 - The Fate of Particular Adventurers.mkv-AnimeConversion-2020-04-23T15-10-29.log (1.4 MB)

It may be a Plex issue in reading subtitles from MP4 files (your original was MKV). The converted file looks fine and has the SRT file embedded into it. Try playing it back with VLC and see if works:

2020-04-23T15:26:10 MCEBuddy.AppWrapper.Base --> Stream #0:2(eng): Subtitle: mov_text (tx3g / 0x67337874), 1920x1080 (default)
2020-04-23T15:26:10 MCEBuddy.AppWrapper.Base --> Metadata:
2020-04-23T15:26:10 MCEBuddy.AppWrapper.Base --> creation_time : 2020-04-23T19:26:02.000000Z
2020-04-23T15:26:10 MCEBuddy.AppWrapper.Base --> handler_name : *eng.srt:hdlr=sbtl:lang=eng@GPAC0.8.0-rev94-g6ada10e30-master

MCEBuddy is creating tx3g subtitles as per the MP4 specs.

EDIT: Looks like Plex has had issues with MP4 subtitles for quite a while. Mp4 with TX3G / Mov_Text Subtitles dont work - Streaming Devices - Plex Forum

Checking now. I deleted it but it only takes a few minutes to go through. Weird thing is its still putting the .srt out there which is totally fine with me, but selecting it doesn’t show subtitles which looks to the the workaround from that thread. Any thoughts while this is going and i test with VLC? I see that the .srt has _eng at the end. Maybe that needs to be the same name as the show file. Ill look into that as that would be a Plex thing though.

So VLC wont even show them. It sees the subtitles and allows me to select them, but still does nothing. Video plays flawlessly.

We changed that one the latest 2.5.4 beta build so it’s compatible with Plex. You can try it out

Yea it doesn’t work in VLC or Plex (the .srt) and subtitles in the video. The video is flawless. Still no joy on subs though. Any other ideas?

I’m just giving up. Nothing i do keeps the subtitles in a way Plex plays them. Ill just leave them the way they are. I ran into something else that doesn’t make much sense so I’ll start a new topic.
Thanks,
Brandon

I’ve actually played with this a bunch of different ways. Plex also has the options to grab subtitles for TV shows directly and is fairly good at it. Only thing you have to be concerned about is matching the show with the subtitle content. Timing usually is an issue when commercials are edited. If you are converting movies you really need to look how the subtitles are embedded. If they are actually in the .mkv (not hard set) file, Handbrake does a really good job of enabling them in a .mp4 file. While windows media player wont necessarily see the option, VLC shows them fine as well as Plex.

Actually just checked. Win 10 ‘Movies & TV’ plays the subtitles as well as VLC, when MCEBuddy converted file fine with subtitles. I would have to reset my Plex server to see if the subtitles get picked up. How are you using Plex (Web, Roku, Firestick) ? Also, if you use a tool like MediaInfo (find good copy), how does it show the subtitle info ?

1 Like

So I managed to get it working with just exporting the subtitles as Goose said. Embedding them seemed to be the issue. Just so happened that closed captioning was off on the TV itself so thats what was stopping that. Never thought to check. Its working fine just extracting them and saving them in the directory as a .srt though. Im good!